Drizzle query with ...
 
Share:
Notifications
Clear all

2022-05-29: APP 2.0.0-beta2 has been released !

Release notes

Download links per platform:

windows 2.0.0-beta2

macOS x86_64 2.0.0-beta2

macOS arm64 M1 2.0.0-beta2

Linux DEB 2.0.0-beta2

Linux RPM 2.0.0-beta2

Drizzle query with mono camera


(@deeko76)
Brown Dwarf Customer
Joined: 4 years ago
Posts: 14
Topic starter  

Hello!

My current setup produces under-sampled data @ 2.49"/px. I always dither my data too and want to try drizzle to try and sharpen my somewhat 'soft' images. As I am using a ZWO ASI294MM mono camera my questions are below:

1) Under tab 0 RAW/FITS if I intend on using drizzle with a mono camera what settings need to go in there as they all seem to apply to OSC cameras? 

2) Under tab 6 INTEGRATE, if I select the 'drizzle' mode option from the bottom under the 'Integrate' section it displays a warning saying I should be using the 'Bayer/X-Trans drizzle' option instead - I am confused by this as it seems like the latter if for OSC?

It would be great to know what the correct settings are for both these tabs to use drizzle with a mono camera.

 

Thanks!


ReplyQuote
Topic Tags
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4830
 

Hi and thanks for the questions;

1) You can leave tab 0 as-is if that works as expected for regular images from your camera.

2) So when you load in an image and see it in the preview, is the histogram on the top right displaying a grey, mono histogram or RGB?


ReplyQuote
(@deeko76)
Brown Dwarf Customer
Joined: 4 years ago
Posts: 14
Topic starter  

@vincent-mod, attached is a screenshot of what I can see when i select one of the images (luminance in this case). I cannot tell if the histogram is displaying a grey or mono.

Capture

 


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4830
 

Ok, so that at least is a mono histogram, same for the G channel for instance? Please also double check if "Force CFA" is not switched on in tab 0.


ReplyQuote
(@deeko76)
Brown Dwarf Customer
Joined: 4 years ago
Posts: 14
Topic starter  

Apologies, I better roll back a bit for a clearer understanding!

If I leave the default settings with the 'adaptive airy disc' algorithm in tab 0 then I get the below histogram for any image from the LRGB filter data (note the colour space is showing as 16b gray and CFA is RGGB?):

 

tab0 airy disc

 

If I change the algorithm in tab 0 to 'no interpolation' then I get the below histogram for any image from the LRGB data and again the colour space shows as 16b gray and CFA RGGB.

tab0 no interpolation

 

If I integrate with adaptive air disc and attempt the 'drizzle' integration mode, the below message is displayed:

 

Capture

 

Given the above, it is not clear to me that regardless of using drizzle or not, that I should actually be changing the settings in tab 0? Also, I am unsure why the data is categorised as CFA RGGB when its from a mono camera?

 

Any help in understanding this would be greatly appreciated! I am about to try and run an integration with the 'no interpolation' algorithm in tab 0 with the 'drizzle' integration mode 0 - I have not tried this yet.


ReplyQuote
(@deeko76)
Brown Dwarf Customer
Joined: 4 years ago
Posts: 14
Topic starter  

This also might be useful, the properties of the image indicates it is tagged as RGGB in the fits metadata:

bayer

I do wonder if my image collection software is tagging the image as RGGB when its a mono camera.


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4830
 

Ah, thank you for the extra research. That last one might indeed be the issue, maybe APT is doing this can you check that? I'm discussing this with Mabula as well.

No interpolation might be an interesting test indeed, to see if that works to get around the issue.


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4830
 

Yes, given the other screenshot, APP is displaying a mono but because of the header, it regards it as RGGB. This should be removed from the fits header. In the next APP version this will be easy to do, but also check that APT is not set to add this.


ReplyQuote
(@deeko76)
Brown Dwarf Customer
Joined: 4 years ago
Posts: 14
Topic starter  

I can confirm that APT has been adding the BAYERPAT keyword with RGGB value to the fits header. This is because I had a 294MC pro OSC previously and I didn't disable the debayer setting for previewing the OSC colour fits files. With this enabled it was writing the BAYERPAT keyword with RGGB to the fits header. I have sourced a tool to batch edit all my fits files to remove the keyword but having trouble with it. I could not remove the BAYERPAT keyword completely but I could modify with the value BAYERPAT = 'no' and APP now works with it. Before this I also tried changing the algorithm to 'no interpolation' without changing the fits headers but that did not work and failed during flats calibration.

The drizzle mode now works as expected with mono data. Like you say, it might be useful to have some kind of override feature to ensure mono data is dealt with properly.

Cheers!


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4830
 

Alright, thanks a lot for the clear description and own research into this. I now know that more people using APT have had this problem, it's not very apparent I guess in the UI. The next release of APP will have a batch modifier tool to edit the fits headers and can be used to tackle this if needed.

Good luck with the rest of the processing! 🙂


ReplyQuote
Share: