Strange image tilin...
 
Share:
Notifications
Clear all

2022-05-29: APP 2.0.0-beta2 has been released !

Release notes

Download links per platform:

windows 2.0.0-beta2

macOS x86_64 2.0.0-beta2

macOS arm64 M1 2.0.0-beta2

Linux DEB 2.0.0-beta2

Linux RPM 2.0.0-beta2

Strange image tiling upon load


(@rhalbers3)
Molecular Cloud Customer
Joined: 4 years ago
Posts: 6
Topic starter  

I just purchased APP earlier today and find myself failing on step 1.  Upon loading an image file of any kind (FITS, Raw, or JPG), the image window shows the image as a 2x2 set of quadrants.  The real image is in the lower-right quadrant.  The upper-right quadrant is vertical lines, the lower-left is horizontal lines, and the upper-left is blank.  I must be doing something embarrassingly stupid, but all my searching for the proper setting to correct this has been fruitless.  I can't find any help in the video tutorials either.  Has anyone else seen something like this and can help get me on the right track?  Many thanks from this baffled new user!

APP Fail

 


ReplyQuote
Topic Tags
(@rhalbers3)
Molecular Cloud Customer
Joined: 4 years ago
Posts: 6
Topic starter  

Out of curiosity, I downloaded APP onto my laptop.  It behaves as expected!  No odd tiled versions of any images I load.  So the issue seems to be related to something on my desktop (where I do all my astrophoto processing, of course).  But what?  A third party library perhaps?  Again, any help or insight would be greatly appreciated.


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4830
 

The issue is OpenGL3. You can see APP is using that on top of the screen. I was under the impression this was fixed as well (we had quite the trouble bug fixing OpenGL3 as the developers of OpenGL had to step in). But, you should have a look if you can upgrade that to OpenGL4, sometimes this is a setting for your graphics card. GL3 is quite old now and the cause of some of these issues.


ReplyQuote
(@rhalbers3)
Molecular Cloud Customer
Joined: 4 years ago
Posts: 6
Topic starter  

That's it!  By clicking on the openGL3 button and reverting to CPU rendering, the problem goes away (see screenshot).  How brilliant is that button in the upper-left corner that both displays your graphics accelerator and allows you to easily disable it?  My desktop is 9 years old, uses Intel integrated graphics, and has the latest display drivers, but does not support openGL4 and is obviously now outdated.  This could be a good excuse for a computing upgrade!  Until then, I'll continue to revert to CPU rendering.  Many thanks for pointing me in the right direction. 😀

APP Success

 

This post was modified 2 years ago by rhalbers3

ReplyQuote
Share: