CRITICAL WARNING: f...
 
Share:
Notifications
Clear all

CRITICAL WARNING: flat-field calibration can not be performed correctly!  

  RSS

(@vsathyan)
White Dwarf Customer
Joined: 3 months ago
Posts: 10
May 13, 2021 20:58  

Hello,

I am getting the following error and not sure how to resolve. Here is what I have.

I took M81 in 4 different nights. All my lights are 300s and I have corresponding Darks at 300s.

For each night I took flats and darkflats using Nina flatswizard. I have 4 sets of flats/darkflats and exposure time is different each day. My flats are 30, darkflats are 16, dark is 16 frames.

While loading them in APP, I did mention sessions 1,2,3,4 for each of those set. For the darks I have one set and set applied to all session while loading.

Please let me know what is wrong and what can I do to fix.

APP Flat error

ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 3 years ago
Posts: 839
May 13, 2021 21:05  

@vsathyan The exposure times of the flats and darkflats need to be exactly the same OR you need to add bias frames. The flats wizard of NINA tends to produce different exposure times when used so in order to avoid having to shoot new dark flats every time, you may want to stick to one set of dark flats and one set of bias so the master dark flat can be properly scaled by APP. That will get you rid of that popup.


ReplyQuote
(@vsathyan)
White Dwarf Customer
Joined: 3 months ago
Posts: 10
May 13, 2021 21:35  

@wvreeven Not sure I get it. All the places I read, flats and darkflats(for OSC which is mine), should be taken every day for the dust movements. Are you saying,

1. Use flats and darkflats from one of the session only or

2. Use flats from all the sessions and use dark from one of the session.

BTW, my flats and darkflats are same exposure for the same day. That is how NiNa creates.

Please clarify.


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 3 years ago
Posts: 839
May 13, 2021 23:11  

@vsathyan Darks and darkflats are taken without any light, as are bias. So they don't need to be taken from day to day. You can create them once a year and reuse them.

Flat, on the other hand, better get taken as often as possible. If you don't disconnect the camera from the telescope and you don't take the telescope from the mount then you can reuse the flats a few days in a row but it certainly is better to taken them as often as possible and preferably every day.

With respect to the APP popup, if the darkflats and flats have the same exposure time then something else is going on. Are you sure they were taken with the same gain, offset and temperature? Also, what do you mean with "My flats are 30, darkflats are 16, dark is 16 frames"? Are you referring to the number of frames taken or the exposure times?


ReplyQuote
(@vsathyan)
White Dwarf Customer
Joined: 3 months ago
Posts: 10
May 13, 2021 23:30  

@wvreeven thanks for getting back. I was told that flats and dark flats have to be same exposure hence I used NINa flat wizard to take it every time I set up my scope. I do take it down every night after session.

the numbers 30, 16 I quoted are number of exposures. 

all my lights are 300s and 101 gain. Dark is also same. my flats and darkflats vary daily but they are same at any given day. I don’t set gain for flats and darflats. This was working sometime ago for another session. Now it is complaining. 


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 3 years ago
Posts: 839
May 13, 2021 23:47  

@vsathyan Could you please upload, say, 5 to 10 flats, darks, darkflats and lights to

https://upload.astropixelprocessor.com/

using upload3 for both username and password? Please create a directory called vsathyan_popup and put the files in there. I'll have a look at them tomorrow. Thanks.


ReplyQuote
(@vsathyan)
White Dwarf Customer
Joined: 3 months ago
Posts: 10
May 14, 2021 00:31  

@wvreeven I am not able to login to upload site with my APP credentials. do I need to create one? Also is there any easy way to upload from APP directly current set of files?


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 3 years ago
Posts: 839
May 14, 2021 00:50  

@vsathyan Please read my comment again. You need to use upload3 for both username and password. 


ReplyQuote
(@vsathyan)
White Dwarf Customer
Joined: 3 months ago
Posts: 10
May 14, 2021 02:06  

@wvreeven thanks. I got some licensing error and app quit. I restarted it and did the same steps, it behaved this time. I can still upload the files if you need. Let me know.


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 3 years ago
Posts: 839
May 14, 2021 11:32  

@vsathyan Good to know that it is working now. Perhaps you hit a rare condition that triggered the popup. There is no need to upload the files for now. Please let us know if you hit this again and we can continue investigating.


ReplyQuote
Share: