Flats refuse to cal...
 
Share:
Notifications
Clear all

2022-05-29: APP 2.0.0-beta2 has been released !

Release notes

Download links per platform:

windows 2.0.0-beta2

macOS x86_64 2.0.0-beta2

macOS arm64 M1 2.0.0-beta2

Linux DEB 2.0.0-beta2

Linux RPM 2.0.0-beta2

[Solved] Flats refuse to calibrate correctly


(@endeavor384)
White Dwarf Customer
Joined: 2 years ago
Posts: 31
Topic starter  

I for the life of me cannot get my flats to calibrate. For over two years, worked great and just for what ever reason, they simply don't work anymore. Exact same files in PixInsight, no issues.

 

APP: 1.083.4 and I also was on 1.083 getting same results before upgrade.

Camera: ZWO ASI2600MM Pro

Process: LRGB Automatic filter assigning of 143 lights, 120/120 flats and dark flats

Settings: All default except Tab 6)Integrate, 85% stack, Average, Quality, Adaptive Rejection, 1st degree LNC 1 iteration, 10% MBB

Every time I'm told flat field correction not able to work in a pop up.

Result: light files show, Light MF BPM CA STAR REG NORM across all four LRGB lights

app applied

Red filter stacked, master red flat

bad flats
master flats
full app view

Previous Issue:

I know when I had my ASI2600MC Pro, I worked with Wouter and we identified that the automatic process was not properly telling the flats to assign to the lights filter. So I tried to do manual load of Lum lights, manually assign lum flats and dark flats, then the rest of the filters, same result.

 

Again, exact same files in PixInsight, no issues.

 


ReplyQuote
Topic Tags
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4850
 

Ok, thanks for sharing. Did you calibrate your flats with flatdarks? Or if you used bias, with an exposure time that's at least 0.2 seconds?


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4850
 

Oh, and what offset do you use in your data?


ReplyQuote
(@endeavor384)
White Dwarf Customer
Joined: 2 years ago
Posts: 31
Topic starter  

@vincent-mod

@vincent-mod Hi Vincent. All calibration files are > .89 s, but if keeping consistent with looking at the red channel, those were 1.9s flats and dark flats. 

When you ask did I calibrate my flats with dark flats, I loaded them like I've always done with the default settings. I just click flats, pick my flats files, allow it to automatically do filter at very bottom, and move on. Dark flats same thing except it defaults to apply to all. So in making sure to test all parameters, I tried the same settings but assigned the dark flats to the same auto filter selection (I use nina, which uses exact same naming convention between lights and flats and .fits files should have the same info to be consistent through and through). Same result though with Critical Warning: Flat-field calibration can not be performed correctly.

 

As far as offsets, I've had the same issues with doing the following settings with other sets of data requiring me to utilize PixInsight again because it works there.

Gain 100 Offset 30

Gain 100 offset 50

Gain 0 offset 30

Gain 0 offset 50


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4850
 

Ok, that should indeed work, would you mind uploading some of the data (like 20 lights, 20 darks, 20 bias/darkflats, 10-20 flats)? Would be good to know if there is a bug or if it makes sense.

If you want, you can upload to our server:


ReplyQuote
(@endeavor384)
White Dwarf Customer
Joined: 2 years ago
Posts: 31
Topic starter  

@vincent-mod named the folder exactly what you proposed. They're uploading at the time of writing this. I don't use darks with the asi2600mm as they're simply not needed when using the dark flats which should be have similarly.


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4850
 

Are you sure the asi2600 doesn't have any hot pixels and such? Otherwise darks can still be very useful. You could maybe consider creating 1 very long dark, no cooling etc, then create a BPM with that and then use the BPM for maybe years even.

Thanks for uploading, please inform me when it's done and I'll try to look asap (please allow for a day).


ReplyQuote
(@endeavor384)
White Dwarf Customer
Joined: 2 years ago
Posts: 31
Topic starter  

@vincent-mod the 52 files are uploaded at this time. I just stuck with all Red filters. Let me know if you want more lights/flats from other filters. 

I may look at doing that next chance I get with the darks.

 

Appreciate your time and help.

This post was modified 4 months ago by Mark Carter

ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4850
 

Looking at it now, couple of observations;

- Seems like you'd need to expose for longer as the data is very much clipping on the left of the histogram. Maybe increasing the gain a little may also help.

- The darkflats seem to be clipping somewhat as well, so also there a longer exposure or a bit higher gain would make things behave better. The flats look ok, but indeed can also expose for longer, just to be able to use the dynamic range better.

I do also get a warning indeed and am not seeing a very clear reason. I'll ask Wouter (other admin) as I think he has this camera as well..


ReplyQuote
(@endeavor384)
White Dwarf Customer
Joined: 2 years ago
Posts: 31
Topic starter  

@vincent-mod

red helix

 Thanks for the advice. I used sharpcap's sensor analysis and then Nina's exposure calculator which suggested the exposure times to swamp noise. They seemed low so I was testing it all out this night's session it to see if it really worked or not 🙂 I was at f/6.3 and 180s exposures for RGB which seemed about par for the course especially fighting a full moon.

 

Attached is the same data set for the red filter and what Pix spat out for me.


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4850
 

I apparently totally looked over the fact you're not using darks or bias for the lights, is that the case? Because that is also required for that calibration to work nicely.


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 5 years ago
Posts: 3159
 

Hi @Mark @endeavor384,

Thank you for sharing your issue and uploading your data.

The warning that you get indicates that both lights and flats need to be calibrated. If you don't load darks nor bias for the lights, then this is what will happen. The sensor offset is not subtracted from your lights and you get overcorrection as a result.

You really need to load darks or bias to get a decent result.

Pixinsight might be able to do it, by taking a non-optimal short cut, taking only a median of darkflats and thereby subtracting an offset instead of proper dark current matching exposure of your light frames. We will make that possible as well going forward but it definitely is not the best way to calibrate your data and I would never recommend it.

Mabula


ReplyQuote
(@endeavor384)
White Dwarf Customer
Joined: 2 years ago
Posts: 31
Topic starter  

@mabula-admin Hi Mabula - I will see if I can't get some darks taken today and try this process again this afternoon.


ReplyQuote
(@endeavor384)
White Dwarf Customer
Joined: 2 years ago
Posts: 31
Topic starter  

@mabula-admin Hi Mabula - added a handful of dark frames to stack -  same result. I'll get those uploaded as well to my file set I provided but flats still not properly calibrating.


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 5 years ago
Posts: 3159
 

Dear Mark @endeavor384,

Your lights, flats, Flatdarks are all bin2x2, the darks that you uploaded are bin1x1. So if you use bin2x2 darks, it will work definitely.

Mabula


ReplyQuote
(@endeavor384)
White Dwarf Customer
Joined: 2 years ago
Posts: 31
Topic starter  

@mabula-admin was able to get it setup and try again. I'm sure it will come to no surprise to you, but you were right 🙂 It is weird though that I used to use the 2600MC pro from ZWO and never used darks and didn't run into this but I created a couple darks to at least have a masterdark to just plug in. 

 

 

Appreciate the help!


ReplyQuote
(@endeavor384)
White Dwarf Customer
Joined: 2 years ago
Posts: 31
Topic starter  

@mabula-admin One follow-up question. In your design, is best practice for dark flats (assuming flats applied), on the screen when loading that says, "to which channel do we need to assign the frame(s)", is the best option to leave at "all channels" or should I "apply 'Filter' header tag or assign RGB/MONO"? With flats I just leave the "apply 'Filter' header tag" but I know dark flats automatically pick "all channels". Just want to confirm that's best practice. Thanks.


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4850
 

Darkflats can be used for all channels yes as it's dark and not dependent on a filter.


ReplyQuote
Share: