Flats Not correctin...
 
Share:
Notifications
Clear all

Flats Not correcting or overcorrecting dust spots


(@whixson)
Red Giant Customer
Joined: 4 years ago
Posts: 162
Topic starter  

I'm using a QHY 268C OSC camera. I have 25 flats and correct with bias or dark flats. Dust spots appear as shallow craters. I use Starkeeper Voyager to collect lights and flats and target 32ck ADUs for the flats. I also re-took the flats with the same result - any ideas?

Flat

 


ReplyQuote
(@drano)
Brown Dwarf Customer
Joined: 1 year ago
Posts: 8
 

I'm having the same results. Haven't been able to figure out yet why. 

Because those rings are dark on one side and light on the other, it appears to me like the flats are somehow not properly registered to the light frames. It's like everything has shifted a few pixels. At first I thought it was due to my filters being slightly out of alignment between the light and flat frames... but it keeps happening even after re-shooting and on multiple projects. I'm using an ASI2600MM with chroma filters.

After running my subs through DSS, the issue did not repeat itself. I have to assume it's a setting.

I'm hoping someone recognizes this issue and can comment with a suggestion.


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 5 years ago
Posts: 3110
 

Hi @whixson and @drano,

I do not recognize this issue and can only assume there is an issue with the data somehow.

To be clear, flats should never be registered/aligned to light frames... they should have the same dimensions as the lights and that is it. If the flat-field calibration has a wrong orientation, then the issue should be found in the capture software I would think where the image orientation is somehow altered with respect to the sensor orientation...

Of course, we can have a look at the data to see if we can understand what is happening here 😉 Just let us know.

Mabula


ReplyQuote
(@whixson)
Red Giant Customer
Joined: 4 years ago
Posts: 162
Topic starter  

Thanks Mabula, my master flat definitely doesn't match the dust artifacts on the integration results, they're shifted by a few pixels. My images were multi-session and involved pier flips, not that it should make a difference. I'm running one night's data now, with two sessions - pre-flip images and post-flip images. After calibration, it looks like the individual images were properly corrected. Waiting for integration results now.

 

Wayne


ReplyQuote
(@whixson)
Red Giant Customer
Joined: 4 years ago
Posts: 162
Topic starter  

So the integration of the subs AFTER the pier flip is NOT well-corrected - it shows the embossed look of the sample I sent earlier! Why would a pier flip cause flats to be ineffective? Ill attache jpgs of the flat and the two integrations

masterFlat
BeforeFlipIntegration
AfterFlipIntegration

 


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1643
 

@whixson Looking at the picture after the flip, there suddenly are red and magenta edges around the image and they are not there in the pre-flip image. Perhaps that's a clue as to what's going on?


ReplyQuote
(@drano)
Brown Dwarf Customer
Joined: 1 year ago
Posts: 8
 

@mabula-admin

Thanks for looking into this, Mabula.

I re-stacked my data in DSS and the artifacts do not appear. I do not think it is a data issue. In fact, they never used to appear in APP either. However, I'm still fairly new to this and I admit that I have been 'playing' around with settings. So, I just wonder if it was something I entered in error.

I went back and tried a few more times with different settings. I had been recently integrating my subs with 2nd degree LNC and MBB turned on. I turned those off entirely and the artifacts were gone!... or at least the effect was now very subtle. I then went back and tried 4th degree LNC (no MBB), they look fine again, or at least much better. I went back and tried replicating the issue, so I selected 2nd degree LNC and MBB once again. However, now the issue has not resurfaced.

I don't know enough about these settings to understand if they are somehow involved, but I have to assume that there must be some correlation.

I also wonder if my flats are being taken with too strong of a light source? I'm using an LED tracing pad and white fabric. I may attempt to dim the source next time and ty again. I'll keep experimenting to see if I can replicate, or at least narrow down, the issue.

I'll keep an eye on this thread in case you have more info.

Thank you

This post was modified 1 year ago by Adriano

ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1643
 

@drano What exposure time are you using for your flats? I am using ASI1600MM, ASI2600MC and ASI6200MM cameras myself and found that exposure times for flats between 2 and 10 seconds are best for these cameras. Certainly not shorter though longer is OK as well.


ReplyQuote
(@drano)
Brown Dwarf Customer
Joined: 1 year ago
Posts: 8
 

Here is one of my Iris Nebula LUM stacks, for reference.

I think the artifact matches pretty closely to what the OP is experiencing.

Iris Nebula LUM St

ReplyQuote
(@drano)
Brown Dwarf Customer
Joined: 1 year ago
Posts: 8
 

@wvreeven

So, I'm using the ASIair pro and allowing the app to run its auto-exposure for flats. It will vary by filter.

For the luminance stack I just shared it was using 50.0ms at Gain 0 


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1643
 

@drano The ASI2600MM has a rolling shutter so 50 ms is WAY too short. Just put several layers of white cloth between the light source and the telescope and make sure you have exposure times of 2 secs or more for all your filters and try again.


ReplyQuote
(@drano)
Brown Dwarf Customer
Joined: 1 year ago
Posts: 8
 

@wvreeven

Thanks, Wouter

I was starting to come to a similar assumption. I can also dim my light source, so I will try to get the exposures up and will report back. Hopefully this will help the OP as well.

👍


ReplyQuote
(@whixson)
Red Giant Customer
Joined: 4 years ago
Posts: 162
Topic starter  

@mabula-admin Where can I upload the data to?


ReplyQuote
(@drano)
Brown Dwarf Customer
Joined: 1 year ago
Posts: 8
 

@wvreeven

@whixson

Just wanted to report back that I had another session with the 2600MM and my 2600MC

I managed to re-shoot my flats and (especially for my LRGB filters) I reduced the brightness of my light panel to it's lowest setting and further diffused it with 3 sheets of paper. This produced the desired effect and I was able to get 5-6 second flats with about 30K-35K ADU. The integrations no longer show any more rings.

This makes total sense because I only ever suffered with this issue with filters that had higher transmission, such as the LRGB. When I was shooting automatic flats via the ASIair on my HSO filters, they would usually end up with at least 2-3 second exposures or higher... even at full brightness settings.

So, moving forward I will shoot LRGB flats with the panel at lowest power setting and HSO at normal brightness setting. For the 2600MC, I typically use a Triad Ultra narrowband filter or an Optolog Lpro, so I'm doing the same with that camera. Low power setting on the light panel for the Lpro, and normal brightness for the Triad-Ultra.

I also started using Dark Flats instead of Bias frames to avoid any similar shutter speed related issues on the master Bias.

So far, so good. No more circles 🙂

@mabula-admin was able to also sort my other "ring" issue by recommending using the 32 bit Masters setting in a different thread.

Thank again for the tips, Wouter and Mabula! 


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1643
 

@whixson Sorry for the late reply. Please upload your data to

https://upload.astropixelprocessor.com/

using upload1 for both username and password. Create a directory called whixson_dust and put your files in there. Let us know here when the upload is done and we'll have a look. Thanks!


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1643
 

@drano Thanks for the feedback. I'm glad to see your issue was solved.


ReplyQuote
Share: