Critical Warning: f...
 
Share:
Notifications
Clear all

[Solved] Critical Warning: flat-field calibration

Page 2 / 2

(@mabula-admin)
Quasar Admin
Joined: 5 years ago
Posts: 3117
 

Hi Sam @hinoshori,

I have looked in detail to your uploaded data, thanks for sharing. I clearly see the problem in your dataset which is causing your issue.

Let me explain: I have loaded all the files and used for all of them (Lights, Flats,Darks and FlatDarks) the filter header tag as you did.

Then this is shown in the frame list, you can maximize it with the little arrow up:

Little Arrows

First we check the lights and flats:

Loaded all images with filter tag

You see from the colors on the lights and flats that the filters are recognised and you also see the filter name in the frame column.

Now the darks and flatdarks:

Loaded all images with filter tag darks flatdarks

These are always shown dark despite a possible filter name.

But the filtername tag which we used for loading is detected and still shown properly in the frame list column. You can now see where it will go wrong already:

Loaded all images with filter tag 10sec darks have bad filter name

The 10 sec darks have a filter name tag of Empty (see fits header):

HDU1 - TELESCOP= 'Redcat ' / Name of telescope
HDU1 - FOCALLEN= 250.0 / [mm] Focal length
HDU1 - FOCRATIO= 4.9 / Focal ratio
HDU1 - FWHEEL = 'ZWOptical FilterWhee' / Filter Wheel name
HDU1 - FILTER = 'Empty ' / Active filter name
HDU1 - OBJECT = 'Darks ' / Name of the object of interest
HDU1 - OBJCTRA = '00 00 00' / [H M S] RA of imaged object
HDU1 - OBJCTDEC= '+00 00 00' / [D M S] Declination of imaged object
HDU1 - OBJCTROT= 0.0 / [deg] planned rotation of imaged object
HDU1 - ROWORDER= 'TOP-DOWN' / FITS Image Orientation
HDU1 - EQUINOX = 2000.0 / Equinox of celestial coordinate system
HDU1 - SWCREATE= 'N.I.N.A. 2.0.0.2024' /

So that creates your issue clearly 😉 These darks will not be used for the 10 sec lights in this manner because the 10 sec lights have a different filter name assigned, so their sensor offset is not subtracted and Flat-Field calibration will not work...

Ask yourself the question if it makes sense to assign a filter name to a calibration frame where there is no filter purpose because no light should be entering the system... the different exposure times of your flatdarks are not an argument for using a filter tag, because APP already uses that for matching the frames with calibration data.

There are 2 very simple ways to prevent this issue from re-occuring:

1) The recommended way is to never load darks, flatdarks (or bias) with a filter header tag. Simply assign them to all channels, don't use a filter tag because it has no purpose 🙂 APP is clever enough to match the correct MasterDarkFlats with your flats based on gain and exposure time 😉 So all will work properly.

2) If you do want to assign a filter header tag to darks, flatdarks, then check the frame list like shown in my screenshots, or even more simple, don't use the filter header tag, but assign the filter name yourself.

Method 1) is the easiest and is very error proof as I explained.

Let me know if this is clear 😉

Oh and I also see a workflow issue with your data itself. You have 30 sec darks with a luminance filter tag and the luminance lights are only 10seconds. And vice versa for the RGB data which are exposed with 30seconds and then the 10 second darks have the Emtpy tag.

If you use method 1) in loading the frames, then APP would even have corrected your filter tags error made in the capture software 😉

Mabula

This post was modified 4 months ago 2 times by Mabula-Admin

ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 5 years ago
Posts: 3117
 

And to make certain, I tested the behaviour in 1.082 and it is exactly the same, so it will also produce the problem in 1.082 as can be seen in the frame list panel after 2)Calibrate finishes:

Same Problem 1.082

Notice that the R,G,B data have no MasterDark assigned... because of the Empty tag which was forced to use by using the filter header tag when loading darks.


ReplyQuote
(@hinoshori)
Brown Dwarf Customer
Joined: 1 year ago
Posts: 12
Topic starter  

Thanks for the detailed reply @mabula-admin !

I think I understand what you're saying. However I did not assign a filter tag to the darks, just to "all channels and all sessions" when loading in the darks. So when I assigned filter tags to everything it looked like this:

app filelist

This threw up the error. (in v1.083 but not v1.082)

After some further testing once I hit integrate with the above it then shows up as in your images:

APP after integrate

I guess I was just expecting the behaviour to be slightly different? If i've selected all channels on the darks but it then detects the fits header filter name for darks if I've assigned filters to the dark flats?

 

 

Going forward I will just let APP handle the calibration frames automatically - I trust you when you say it's probably smarter than I am 😉

 

As for the workflow error, I think that's a limitation of NINA, if I choose to run darks in it, by leaving the filter option blank it seems to record into the fits header and the filename the current filter. (Just checked this to see if it was user error).


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 5 years ago
Posts: 3117
 
Posted by: @hinoshori

Thanks for the detailed reply @mabula-admin !

I think I understand what you're saying. However I did not assign a filter tag to the darks, just to "all channels and all sessions" when loading in the darks. So when I assigned filter tags to everything it looked like this:

app filelist

This threw up the error. (in v1.083 but not v1.082)

Hi Sam @hinoshori, notice that still you have loaded the flat darks with using the header tag... flat darks are darks so just assign those to all channels. APP will match them correctly with your flats based on the exposure times.

But if I load it like that, indeed, I do get the issue and it should not happen, so we need to fix this ! And I will.

Thank you very much for reporting this.

After some further testing once I hit integrate with the above it then shows up as in your images:

APP after integrate

I guess I was just expecting the behaviour to be slightly different? If i've selected all channels on the darks but it then detects the fits header filter name for darks if I've assigned filters to the dark flats?

 I showed this to illustrate the issue with the filter tags in your data and why you don't want to be vulnerable to that, which happens when you assign a filter tag or use the header filter tag of darks/darkflats. You really don't want to do that.

 

Going forward I will just let APP handle the calibration frames automatically - I trust you when you say it's probably smarter than I am 😉

 

As for the workflow error, I think that's a limitation of NINA, if I choose to run darks in it, by leaving the filter option blank it seems to record into the fits header and the filename the current filter. (Just checked this to see if it was user error).

So it should look like this, if you load all darks and flatdarks with assignment to all channels :

Method1 best error proof way

And this will not throw an error in 1.082 nor in 1.083

I will make sure that the error with loading the flatdarks with fitler header tag is fixed as soon as possible.

Thanks!


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 5 years ago
Posts: 3117
 

Hi Sam @hinoshori @moviecells, @wvreeven, @vincent-mod

I have fixed the issue. It was a concurrency issue which I introduced in the 1.083 release. It is fixed for a new release 1.083.2 which I will release soon.

https://www.astropixelprocessor.com/community/release-information/astro-pixel-processor-1-083-2-preparing-release/

Thank you very much for your detailed reporting of the issue.

Mabula


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 5 years ago
Posts: 3117
 

Hi Sam @hinoshori,

The fixed version is available 1.083.2 😉 Downloads are at the top of the forum !

Thank you once more for reporting this issue.

Mabula


ReplyQuote
(@hinoshori)
Brown Dwarf Customer
Joined: 1 year ago
Posts: 12
Topic starter  

@mabula-admin 

Great, thanks for all the help!


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 5 years ago
Posts: 3117
 

You are most welcome Sam @hinoshori 😉 !


ReplyQuote
Page 2 / 2
Share: