Critical Warning: f...
 
Share:
Notifications
Clear all

[Solved] Critical Warning: flat-field calibration

Page 1 / 2

(@hinoshori)
Brown Dwarf Customer
Joined: 12 months ago
Posts: 12
Topic starter  

Morning,

Recently since I updated to the latest version of APP I've started to get the "flat-field calibration can not be performed correctly!" error.

I am stacking the following:

L 10s

RGB 30s

Darks 10s, 30s

Flats L 1s, R 1.1s, G 1.24s, B1.0s

Dark Flat L1s, R 1.1s, G 1.24s, B1.0s

 

Additionally as part of my troubleshooting I tried putting the L data into a seperate session with the same error occuring. Curiously if I run each filter individiually I do not get this error.

Am I missing something blatently obvious?

 

Thanks!

APP error

 EDIT: SOLVED PER RELEASE 1.083.2 : https://www.astropixelprocessor.com/community/release-information/astro-pixel-processor-1-083-2-preparing-release/

This topic was modified 4 months ago by Mabula-Admin

ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4690
 

I'm suspecting this pops up because you're combining mono and RGB data in 1 session. Not sure why it goes wrong on this spot, possibly the algorithm in tab 0 is set to RGB specifically by you? Anyway, at the moment it's better to process mono data on its own as well as RGB data on its own. If you want to combine both, it's best to split the RGB to mono first.


ReplyQuote
(@hinoshori)
Brown Dwarf Customer
Joined: 12 months ago
Posts: 12
Topic starter  

Sorry I meant R,G,B not "RGB." All data is mono from the 1600mm

I also had the pop up when stacking narrowband data.

 

Capture

ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4690
 

Ok, then it might be an issue with the calibration data possibly. If you could upload say 10 subs of each channel and 10 of each calibration data you used as well as the master calibration frames, that would be great.

Go to https://upload.astropixelprocessor.com and for the username and password, use: upload

Create a directory named “hinoshori-flatCalWarning” and upload in there. Thank you!


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1636
 

@hinoshori Yes please upload some data as Vincent requested.

Also, to be absolutely sure, you did shoot all lights and calibration frames with the same software, software version, gain, temperature and offset, right?


ReplyQuote
(@hinoshori)
Brown Dwarf Customer
Joined: 12 months ago
Posts: 12
Topic starter  

@wvreeven

Data is uploading as we speak.

All images were shot on a clean install of windows with the latest nightly of NINA, G75 Offset 56, -20c


ReplyQuote
(@hinoshori)
Brown Dwarf Customer
Joined: 12 months ago
Posts: 12
Topic starter  

Data upload complete 🙂


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1636
 

@hinoshori Thanks very much. I have loaded all raw data (I ignored the master files created by you) into one session and hit the integrate button. Calibration goes fine and now APP already is integrating the lights. Is this the full data set? If not, can you try with the data that you uploaded and see if you can reproduce your error?


ReplyQuote
(@hinoshori)
Brown Dwarf Customer
Joined: 12 months ago
Posts: 12
Topic starter  

The data provided was only a small sample. (Don't think my upload speed could handle the full data set!)

So I loaded the data in that I provided into one session (10 files from each calib & light), got the same error at the same position. 

 

APP errorrestricteddata
1
2 2
2 1

ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1636
 

@hinoshori I see you loaded both the raw calibration data and the masters. I did not load the masters. Can you try again with the masters and confirm that you do don't get the error then?


ReplyQuote
(@hinoshori)
Brown Dwarf Customer
Joined: 12 months ago
Posts: 12
Topic starter  

@wvreeven

They were showing as loaded at that point because I cancelled the stack mid way through after the error was thrown up. But I ran it without them


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1636
 

@hinoshori Ah, OK, I see. I'll need to ask Mabula about this then. What OS and OS version are you on?


ReplyQuote
(@hinoshori)
Brown Dwarf Customer
Joined: 12 months ago
Posts: 12
Topic starter  

Windows10 21H1 19043.1466

 

Thanks for trying!


ReplyQuote
(@moviecells)
Main Sequence Star Customer
Joined: 2 years ago
Posts: 99
 

Hi All

Not sure if this may be the same problem but with this new version if i load a batch of flats and matching darkflat to make up some masters i get the same error. There clearly is matching files for both only way around this for me was to make some master darkflats first then use the master darkflats to process the flats to then get my masterflats. It does not seem to like making two master up at the same time.

Whats even more strange if i ignore the error then compare the final masters for both methods seem same like there was no error ?

Mike


ReplyQuote
(@hinoshori)
Brown Dwarf Customer
Joined: 12 months ago
Posts: 12
Topic starter  

As a bit of a sanity check I reinstalled V1.082 loaded the exact same data and the calibration ran through with no errors... if that helps?


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1636
 

@hinoshori Mabula will have a look at your data and inspect the differences between APP 1.082 and 1.083.

Meanwhile, do you assign the dark flats to the corresponding filters manually? Because I did not. I simply loaded the lights, flats, darks and dark flats without selecting any filter and let APP decide that. Then I went to tab 6 and clicked the integrate button. Do you still get the popup if you do that as well?


ReplyQuote
(@hinoshori)
Brown Dwarf Customer
Joined: 12 months ago
Posts: 12
Topic starter  

@wvreeven

So on all the previous runs I've assigned the filters manually on all the calibration frames.

Following your instructions and just adding the images without manually selecting allowed the calibration to run without error.

I'm guessing this is because whilst I shoot flats & dark flats for each filter to account for the different exposure times, in this case for the B & L calibration sets the exposure times were both 1s (previously my flats & dark flats have usually had different exposure times), and whilst the dark flats are exposure length dependent they are not filter dependant. 

Maybe some conflict arrising due to the same exposure length and being assigned to different filters?

Watching the log as it ran through after not assigning filters to the DFs i saw 20 files being integrated for one of them. Output was 3 MDF's, vs 4MDF's when assgning filters to them.

Curious though that the old version ran through with no errors!


ReplyQuote
(@moviecells)
Main Sequence Star Customer
Joined: 2 years ago
Posts: 99
 

@hinoshori

Hi in my case with errors when making my masters it could a common problem

when i load my flats i select use filter header to apply them

when i load my darkflat i do the same use filter header

and before you ask i know filter types do not matter they are dark frames i know and it the times that are important but in older releases it seem to help avoid this error matching up the files. But now it seems to cause an error. If your files have the correct filters then matching times should not matter so may be that why its working for you now.


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1636
 

@hinoshori @moviecells In general it is better to not assign a filter to any files and let APP handle it. Having said that, I will pass on the info that not manually setting the filters in this case now works while assigning them in this case doesn't. I'll let him get back to you about this.


ReplyQuote
(@hinoshori)
Brown Dwarf Customer
Joined: 12 months ago
Posts: 12
Topic starter  

@wvreeven

Thanks for your help!


ReplyQuote
Page 1 / 2
Share: