APP Crashes randoml...
 
Share:
Notifications
Clear all

Please note our new Downloads page here

2023-01-19: APP 2.0.0-beta13 has been released !

!!! Big performance increase due to optimizations in integration !!!

and upgraded development platform to GraalVM 22.3 based on openJDK19

 

We are very close now to  releasing APP 2.0.0 stable with a complete printable manual...

 

Astro Pixel Processor Windows 64-bit

Astro Pixel Processor macOS Intel 64-bit

Astro Pixel Processor macOS Apple M Silicon 64-bit

Astro Pixel Processor Linux DEB 64-bit

Astro Pixel Processor Linux RPM 64-bit

APP Crashes randomly without error messages


(@richardxox)
Hydrogen Atom Customer
Joined: 3 years ago
Posts: 2
Topic starter  

Hi,

I have recently run into a problem that astropixel processor is randomly crashing without any errors when I am trying to integrate a relatively large amount of frames together (more than 100). I have around 2T free space in my working directory and I have all of my 15Gb out of 16GB total memories allocated for astropixel processor to do the processing. I am running a windows OS with a pretty fast i7 processor.  I wonder what will be the possible cause for this kind of problem? I did not have any problem integrating say 40 frames together before but when I tried to increase the frames to 100 or more it crashes randomly during the integrating step. I am using 2nd-degree LNC, 3 iterations, 10% MBB, and a 2 times drizzle on the image.

 

image

 

Thanks

Richard

This topic was modified 2 years ago 2 times by Richard Xiong

ReplyQuote
Topic Tags
(@vincent-mod)
Universe Admin
Joined: 6 years ago
Posts: 5229
 

It may be a memory issue, possibly. You're giving APP the same amount as your system has and that might mean it uses so much, the system has nothing left. Could you try lowering the amount of memory to, say, 12 GB and try again?


ReplyQuote
(@richardxox)
Hydrogen Atom Customer
Joined: 3 years ago
Posts: 2
Topic starter  

@vincent-mod I tried to click on the CFG button on the upper lefft corner and nothing shows up there is no window popping up. Is there another way I could change the memroy allocation for APP?


ReplyQuote
(@vincent-mod)
Universe Admin
Joined: 6 years ago
Posts: 5229
 

Oh, that is very strange. Are you by any chance on MacOS Big Sur? Seems we have some issues there for some people.


ReplyQuote
(@romonaga)
Molecular Cloud Customer
Joined: 10 months ago
Posts: 6
 

I am also faced with this issue.  I thought I had the issues resolved when I found a bad frame, however it seems that large datasets are causing issues for the BETA.  I had to rollback to a stable version in order to do large integrations.

I can find no error message; the application simply vanishes or causes a reboot of the machine.  I would be very happy if it simply crashed and did not take my server with it.

I am running on Ubuntu, 20.04.  At latest patch levels.

128 Gig for Ram

6TB disk space

24 threads (I9 12 Gen)

I know there is an issue when it finds a bad frame, in one case, somehow, the camera took half an image.  That caused APP to just lockup, not crash.


ReplyQuote
Share: