If the calibration ...
 
Share:
Notifications
Clear all

[Solved] If the calibration frames are different from the principle.

Page 2 / 2

 momo
(@mo-mo)
Main Sequence Star Customer
Joined: 6 months ago
Posts: 86
Topic starter  

@wvreeven

I uploaded the specified files.
Please check them.

Thank you


ReplyQuote
 momo
(@mo-mo)
Main Sequence Star Customer
Joined: 6 months ago
Posts: 86
Topic starter  

@wvreeven

According to "[Sticky] Data calibration principles/rules - must read ! "

Flat Frame, Light Frame calibration has three options.

Can I choose a option with APP freely? Or do APP automatically choose it?

 
 

ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1647
 

@mo-mo Just let APP choose it. I'll have a look at your data as soon as possible. Unfortunately it looks like that won't be today, sorry.


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1647
 

@mo-mo I did manage to find some time to have a look at your data.The temperature and other settings of the files look OK to me. The only thing that is confusing is the fact that the FITS headers of the darks and bias miss the GAIN keyword, while the lights and flats do have it. All files have an EGAIN keyword (so the lights and flats have both GAIN and EGAIN). APP displays the value of EGAIN when GAIN is absent. The values of EGAIN for all files agree very well, so I am confident dat the darks and bias were shot at the same GAIN as the lights and flats. But MaximDL apparently doesn't store the value of GAIN in the FITS headers of darks and bias.

Apart from that all files were shot at the same temperature of -10º C, except for the bias which were shot at about -6.5º C. This is not great since this will lead to overcorrection when the bias are applied but the difference in noise for this camera between -10º and -6.5º is not very large so it should be fine.

Since this is a color camera, it looks like the Bayer pattern is missing from the FITS headers of all images. So in tab 0 I set the pattern to RGGB (which is the correct pattern for ASI2600MC) and enabled Force CFA. Then in tab 1 I loaded the lights, flats, darks and bias. And I entered a name of the object (in this case I put Rosetta). Then I went to tab 6 and clicked the integrate button. The result was this image:

Screenshot 2022 01 21 at 16.12.36

When I do not load the flats but keep everything else the same, I get:

Screenshot 2022 01 21 at 16.19.42

So it seems to me that the flats are not correct.


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1647
 

@mo-mo Indeed the flats look wrong. I took this screenshot after loading a flat in APP with pattern set to RGGB and Force CFA enabled in tab 0:

Screenshot 2022 01 21 at 16.23.06

Look at the histogram to the upper right. There is not enough blue data in the flat! I don't know how they take the flats but it doesn't look like they are using the correct light source.


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 5 years ago
Posts: 3117
 
Posted by: @mo-mo

1.Bias should be the same gain as flat.
2.Flat does not have to be the same gain as light.
3.By lowering the gain of flat, the bias gain is also lowered (same as flat)to make the exposure time about 0.5 seconds.

4. I need to make dark and bias gain the same as light gain 100

5.if I change the gain on dark or bias, Another bias or darkflat (dark with the exposure lenght and gain of the flat) for the flats is needed.

 

Hi @mo-mo,

1) Bias should be same as flat and bias should be same as light, so if flats have different gain than lights, you need to create 2 batches of gain frames. 1 batch with the same gain as lights and 1 batch with the same gain as flats.

2) Indeed, flats can perfectly have a different gain than lights

3) Yes, by lowering the gain it is easier to make the exposure time of flats a bit longer which will make better flats. If you make flats with exposure times less than 0,1 seconds, you could experience unexpected problems...which you want to prevent

4) Indeed

5) Yes, see my response in 1

Hope this clarifies things.

Mabula


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 5 years ago
Posts: 3117
 

Hi @mo-mo,

I have also studied your data. Thank you for uploading 😉 I have looked at all the frames in detail... the flats, bias and darks.

Finally, I had a look at the indivdual lights, which look rather good. I see hardly any vignetting that needs correcting, so I have processed your lights without any calibration frames, so no bias, darks nor flats were used, I only used a Bad Pixel Map to correct possible hot pixels still present:

Lights Were Already Calibrated I Think

This looks very okay to me ! So the question now comes to mind: were the lights not already calibrated perhaps? And if so, you are now trying to calibrate, already calibrated data, which perfectly explains strong flat overcorrection.

Mabula


ReplyQuote
 momo
(@mo-mo)
Main Sequence Star Customer
Joined: 6 months ago
Posts: 86
Topic starter  

@wvreeven

Hello

I also got Integrate not using FLAT (but Dark and BIAS used).
It looks like your result. I agree with the fact that FLAT by the service provider is caused .

Mr. Mabra suggested that Light may have already been calibrated, so I also need to confirm that point.

 


ReplyQuote
 momo
(@mo-mo)
Main Sequence Star Customer
Joined: 6 months ago
Posts: 86
Topic starter  

@mabula-admin

Hello

Thank you for checking my files.
I also integrated without using a calibration file at all.
I used 69 light. It became the same as your result
I used the light provided by the service provider as it was.
It is Light that I have not added anything.
It is a service provider that provided to me calibrated light files, but I can not understand why they put effort expressly to calibrate.They do not need to do it.

About the calibrated light that you pointed out, I will talk with the service provider. 
Thank you for using a your valuable time.

This post was modified 4 months ago by momo

ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 5 years ago
Posts: 3117
 

Hi @mo-mo,

You are most welcome, I am glad that we have solved the issue now. Yes talk with your data provider about the calibration of the data 😉 Most data providers can give you both the calibrated data and the uncalibrated data so you can do it yourself with APP !

Mabula


ReplyQuote
 momo
(@mo-mo)
Main Sequence Star Customer
Joined: 6 months ago
Posts: 86
Topic starter  

@wvreeven

Hello

I got an answer from you that APP selects an option automatically.

Is there a way I choose an option?

For example, can I choose by loading only some of Dark, Flat and BIAS?
When multiple options are possible, I want to determine the option and

compare the results.

 


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1647
 

@mo-mo Of course you can choose the options there and see how they influence the result. I think you'll find that the default options work best for your camera. 


ReplyQuote
Page 2 / 2
Share: