Share:

OSC - CFA question  

  RSS

(@wglogowski)
White Dwarf Customer
Joined: 2 years ago
Posts: 16
January 16, 2019 21:42  

Hello, I shoot with a OSC camera (ASI1294pro) and when I begin I toggle under the RAW/FITS "force Bayer CFS" and I select the Bayer pattern of the camera.  When I look at the file view (at the bottom of the window) I noticed that the column labled "CFA" says "No" for all of my light frames.  Does this mean that Astropixel process did not recognize the lights as OSC images?  I do notice that the master flat, dark, and bias are listed as RGGB, my bayer pattern of the camera.  Any thoughts?


ReplyQuote
Topic Tags
(@mabula-admin)
Quasar Admin
Joined: 2 years ago
Posts: 2128
January 17, 2019 12:30  

Dear Walter @wglogowski,

The fits frames don't have proper meta data to indicate that your frames are OSC frames that need to be debayered. So therefore there is no way for APP to know that these are OSC frames. That is the reason why you see "No" in the CFA column.

So before processing your frames, you will need to enable the Force Bayer CFA setting, like you already did as I understand, and make sure that you set the correct Bayer Pattern for your camera. By doing, this you force/tell APP that your data is Bayer CFA data. So when you create the master calibration frames, APP will automatically add the proper meta data to the Masters to indicate these are Bayer CFA Master frames. That is the reason that the Masters will show the correct Bayer pattern in the CFA column.

The missing metadata in the fits frames of your camera are due to the used capture software normally. A program like SGP will not add the proper the metadata unfortunately.

Kind regards,

Mabula

This post was modified 8 months ago by Mabula Haverkamp - Admin

Main developer of Astro Pixel Processor and owner of Aries Productions


ReplyQuote
(@jonesdee)
Main Sequence Star Customer
Joined: 2 years ago
Posts: 35
January 18, 2019 14:06  

Hi Mabula

Further to Walter's post above, I have also just started to use an ASI294 Pro (OSC) camera and would like to know if the colour balance of my Flats is important (i.e. does APP process calibration frames as colour or grayscale?).

When I 'Force Bayer CFA' and view my flats they appear in colour on the screen (usually yellow or green) and the hue varies in accordance with the light source used for taking the flat frames.  If colour content is important, I make an effort to ensure that the source is as neutral as possible.

For reference, Astro Photography Tool (APT) does not include the OSC metadata either 🙂

Thanks and regards

Dave

 

This post was modified 8 months ago by Jonesdee

ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 2 years ago
Posts: 2128
January 19, 2019 20:14  

Dear Dave @jonesdee,

Further to Walter's post above, I have also just started to use an ASI294 Pro (OSC) camera and would like to know if the colour balance of my Flats is important (i.e. does APP process calibration frames as colour or grayscale?).

Color balance in principle of your flats is not very important. I think there is a big misconception in the community about this and some software packages do mess up in this regard in how they apply flat-field calibration.

What is important however for your flats of your OSC camera is that the illumination in all channels (R,G,B) is adequate. Adequate means that

  • the histograms per channel are not clipping on either side of the histogram
  • the histogram peak is in the ADU range where the sensor behaves linearly. Now for most new sensors, this is almost the entire data range of the bit depth of the sensor. For older camera's, it's safer and better to have the histogram peak not higher than 2/3 of the histogram's data range (the horizontal axis).

So if your flats comply with these 2 rules, the flats may be green, red or blue and should still give the same outcome if the flat-field calibration is done properly in software. In APP it will.

As a side note, if one of the channels of the flat is illuminated very weakly and one other channel is illuminated very well,  nearly clipping the right side of the histogram, you could get quality differences (noise levels) in the different channels after flat-field calibration. So if you can create a illumination source so the separate channels are illuminated rather equally, you will get more optimal results.

When I 'Force Bayer CFA' and view my flats they appear in colour on the screen (usually yellow or green) and the hue varies in accordance with the light source used for taking the flat frames. If colour content is important, I make an effort to ensure that the source is as neutral as possible.

Yes, the flats will show color as they should have then ;-). Please realise that the color that you see with your eyes can be rather different than the color that your camera measures/sees 😉 Most camera's are most sensitive in the green wavelengths so for such a camera a magenta light source would look more white than it would for your eyes... Too often this is overlooked I think. But like I indicated in response to the first questions: color content of your flats should not matter if you follow the 2 rules mentioned 😉

Thanks Dave,

Kind regards,

Mabula

Main developer of Astro Pixel Processor and owner of Aries Productions


ReplyQuote
(@jonesdee)
Main Sequence Star Customer
Joined: 2 years ago
Posts: 35
January 20, 2019 00:42  

Hi Mabula

Many thanks for a very clear and detailed explanation!  Although the RG&B peaks in my flats are separated by a small amount, neither the blacks nor whites are clipped, so I think that I am fine continuing with my current method of shooting flats.

Best regards

Dave


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 2 years ago
Posts: 2128
January 20, 2019 11:44  

Sounds excellent Dave @jonesdee

Kind regards,

Mabula

Main developer of Astro Pixel Processor and owner of Aries Productions


ReplyQuote
(@1cm69)
Neutron Star Customer
Joined: 2 years ago
Posts: 132
March 14, 2019 12:13  

OK, I just found this thread & think this may shed some light on an issue that I am experiencing as I have detailed here: https://www.astropixelprocessor.com/community/main-forum/ha-test-with-poor-results/paged/2/#post-5651

Because I am shooting through a H-alpha filter using my DSLR I see a large separation between the RED channel, being as far to the right as I can get it and the remaining BLUE & GREEN channels being way to the left.

This does not seem too bad on the individual Flats but the Master Flat causes the BLUE & GREEN channels to be clipped left resulting in excessive noise in my final Integration.

Kirk


ReplyQuote
Share: