Beta 2.0 - APP free...
 
Share:
Notifications
Clear all

2022-05-29: APP 2.0.0-beta2 has been released !

Release notes

Download links per platform:

windows 2.0.0-beta2

macOS x86_64 2.0.0-beta2

macOS arm64 M1 2.0.0-beta2

Linux DEB 2.0.0-beta2

Linux RPM 2.0.0-beta2

Beta 2.0 - APP freeze for about 60-90s through File browser


(@passerati)
Molecular Cloud Customer
Joined: 1 year ago
Posts: 7
Topic starter  

Hello everyone, after installing Beta2 on a Windows 11 laptop, I noticed the following:
If you want to change the working directory, or just want to add the lights, darks, etc., the system hangs again and again for about 60-90s. Jumping around in the file browser is therefore a real game of patience. Downgrading to the latest 1.083.4 fixes the problem.

Has this happened to anyone else?


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4919
 

I remember this to have been an issue before, but can't remember quite what caused that. Are the directories you're looking in local or network based, or maybe usb connected? Are you using any virus scanner that might interfere somehow?


ReplyQuote
(@passerati)
Molecular Cloud Customer
Joined: 1 year ago
Posts: 7
Topic starter  

Hello, I only use local drives in APP. Network drives (NAS) are also connected, but are not used in the APP. The pauses come as soon as I want to change a directory in the browser or I want to integrate files before the browser even appears. Sometimes 2-3 directory changes go without a break, but most of the time APP seems to stand still for the 60-90s. USB drive is not connected. Virus scanner is only the Windows Defender active in Windows 11, but has not reported anything. After downgrading to the last release everything is fine again.


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1782
 

@passerati Hi André. What does "local" mean in this case? Are those internal drives or HDD connected via a USB cable? In case of the latter, does the issue go away if you copy the data to the internal drive?


ReplyQuote
(@passerati)
Molecular Cloud Customer
Joined: 1 year ago
Posts: 7
Topic starter  

Hello, they are all internal drives. Internal NVMe/SSD in the laptop.
Laoptop is a Lenovo Legion S7i with i9-10980HK, 32GB Ram, 1x1 TB SSD, 1x512 GB SSD, RTX2060, 4K display. No USB or network drives where the data is located. APP is normally installed on C:\Program... and sometimes for testing on D:\App\... Also tried with the highest privileges and started as admin. Unfortunately without success. Only with the official version does it always work as before.


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4919
 

It could be that APP is still trying to display the NAS directories, I remember that this was an issue for someone else. Are these always available? If not, enabling those may solve the delay. If it indeed is a beta issue, we will investigate that.


ReplyQuote
(@passerati)
Molecular Cloud Customer
Joined: 1 year ago
Posts: 7
Topic starter  

Hello and thanks for the answer. Unfortunately, it doesn't matter whether the NAS is on or off. Just tested again. When the file explorer is open, I can sometimes click through the directories a few times if I'm lucky. Then the breaks come again.


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4919
 

Strange, not sure if this is a big hassle, but removing the nas drives from the system, does that help? I did notify Mabula, might still be something we need to tackle.


ReplyQuote
(@passerati)
Molecular Cloud Customer
Joined: 1 year ago
Posts: 7
Topic starter  

I made another attempt and installed APP Beta on my observatory computer. There were no breaks here. The same NAS drives are integrated on this one as on my other computer. I then started APP Beta again on my main computer and lo and behold, no more breaks in the file browser. Possible cause: on my main computer I have integrated an additional network drive in addition to the NAS drives, namely a shared folder on the observatory computer, which is otherwise always switched off. Now during the test he was reachable. Maybe that's because of it. But strange that it didn't cause any problems up to 1.083.4.


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4919
 

There were a few changes I believe in that part, so that might have had an influence, but indeed that must be the issue. APP's dialog is trying to reach these destinations and if they are not available, while APP can't tell they are not, it may cause this. I'm not sure we can easily fix this at the moment, but we are trying to use a different file dialog in a future version which may solve this as well.


ReplyQuote
Share: