Mosaic Banding Issu...
 
Share:
Notifications
Clear all

Please note our new Downloads page here

2023-01-19: APP 2.0.0-beta13 has been released !

!!! Big performance increase due to optimizations in integration !!!

and upgraded development platform to GraalVM 22.3 based on openJDK19

 

We are very close now to  releasing APP 2.0.0 stable with a complete printable manual...

 

Astro Pixel Processor Windows 64-bit

Astro Pixel Processor macOS Intel 64-bit

Astro Pixel Processor macOS Apple M Silicon 64-bit

Astro Pixel Processor Linux DEB 64-bit

Astro Pixel Processor Linux RPM 64-bit

[Solved] Mosaic Banding Issue in 2.0.0-beta6


(@david)
Brown Dwarf Customer
Joined: 4 years ago
Posts: 14
Topic starter  

There seems to be a banding issue, or perhaps I am missing a setting, in 2.0.0-beta6 that was not present in 1.083 when processing mosaics.

bandng issue

Using the exact same FITS files and the exact same settings, the beta version presents banding in the final image.

Using the previous version, the image is perfectly smooth and has no defects.

Is there a setting I am missing to prevent this?


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 6 years ago
Posts: 3426
 

Hi David @david,

Thank you very much for reporting this, another user also see this problem, see something is off indeed. Can you share the data on which this occurs so I can test it a.s.a.p. ?

Which settings are you using in 5)Normalize, and which settings for LNC and MBB?

Please upload it here:

https://upload.astropixelprocessor.com/

username: upload

password: upload

Please make a folder with your name and issue description like: David-square-artefactand upload your data there and let me know once done so I can test quickly.

Mabula

This post was modified 3 months ago by Mabula-Admin

ReplyQuote
(@david)
Brown Dwarf Customer
Joined: 4 years ago
Posts: 14
Topic starter  

@mabula-admin 

The files are in david-schneider-square-artifact

5) Normalize is: mode regular, method multiply-scale, scale BWMV, neutralize background is checked, scale is 1.0, interpolation method is lanczos-3, apply registration to frames is checked

LNC is LNC Degree: off, LNC iterations: 3

MBB is 25%

I hope this helps!


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 6 years ago
Posts: 3426
 

Hi David @david,

I think that there is no problem here. I get the same results with the old and stable 1.083 versus 2.0.0-beta6 with the same settings in normalization + MBB + LNC.

If I process the mosaic with regular normalization and MBB 10% and LNC 2nd degree I get this when combining the data with RGBSHO in the RGB Combine Tool:

FIXED LNC2ndDegree

So those banding artefacts are gone then.

Enabling LNC will correct the normalization issue that you see in the mosaic overlap areas. You have the bright nebula in the overlap area and this makes things difficult for normalization as it is in APP. LNC is there to further improve things 🙂

Mabula

 


ReplyQuote
(@david)
Brown Dwarf Customer
Joined: 4 years ago
Posts: 14
Topic starter  

Hello, @mabula-admin !

Thank you for the investigation, and yes, this completely solves the banding!

Thank you again!


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 6 years ago
Posts: 3426
 

You are most welcome David @david !


ReplyQuote
Share: