Share:
Notifications
Clear all

Please note our new Downloads page here

2023-01-19: APP 2.0.0-beta13 has been released !

!!! Big performance increase due to optimizations in integration !!!

and upgraded development platform to GraalVM 22.3 based on openJDK19

 

We are very close now to  releasing APP 2.0.0 stable with a complete printable manual...

 

Astro Pixel Processor Windows 64-bit

Astro Pixel Processor macOS Intel 64-bit

Astro Pixel Processor macOS Apple M Silicon 64-bit

Astro Pixel Processor Linux DEB 64-bit

Astro Pixel Processor Linux RPM 64-bit

APP 2.0 BETA4


(@romonaga)
Molecular Cloud Customer
Joined: 10 months ago
Posts: 6
Topic starter  

I am hoping someone can help, or at least provide me info on how I can determine the issues I have been having with APP after upgrading to the 2.0 BETA.

I am running Ubuntu 20.04, system is updated.  I am running a 12 Gen I9 with 128 GIG of memory.  I am running the software and processing data that resides on 6T of NVME Gen 4 drives.  Graphics card is GForce 3080.

I have done the obvious things like uninstall, reinstall the software, insure I am at correct versions of libs.

The issues i see are APP just stop processing, it will get to about 80% and stall.  The other issue is at times, it just hard freezes the machine, and several times it caused the machine to reboot.

The data set that I can constantly get it to fail (Lock up the Linux machine) is 60 frames of NGC7380 that was done over 2 nights. Not even close to the largest data set that I have processed with APP.  However, without fail, when I try to process this data from the 2 nights, during integration my machine hard freeze's and requires a reset of the machine.

I can not even say how frustrating this is, and how long it takes or my machine to check drives and restart. I can not find any errors logged.  Tonight I will rollback to the version to see if these issues can be reproduced.


ReplyQuote
(@romonaga)
Molecular Cloud Customer
Joined: 10 months ago
Posts: 6
Topic starter  

Well like anything, ask a question, try a few more things out, and solutions, well at least for the Freezing while processing this data.

I reverted back to the stable version, and it was able to process with no errors, however the final results looks like someone blasted half of it with light.  This caused me to go back and examine the frames.  What I found was somehow I had half an image, the top half was fine, the bottom half was all white.

I removed this image and reprocessed and once I was happy with results, I installed the BETA 4 and ran the same process without the bad image.  I was able to process the data just fine.  So, not sure why this half image caused a lockup, but I have the data and if needed I can provide.


ReplyQuote
Share: