AstroPixelprocessor...
 
Share:
Notifications
Clear all

AstroPixelprocessor hangs when started under MacOS Big Sur  

Page 3 / 6
  RSS

(@supercreative)
Molecular Cloud Customer
Joined: 8 months ago
Posts: 5
November 20, 2020 07:58  

Big Sur has been released now, how long until a working version of APP is ready to go?


ReplyQuote
(@wvreeven)
Black Hole Admin
Joined: 2 years ago
Posts: 474
November 20, 2020 09:38  

@supercreative

The current version of APP is working for several users, including myself, on Big Sur.


ReplyQuote
(@j-notht-online-de)
White Dwarf Customer
Joined: 1 year ago
Posts: 10
November 20, 2020 10:32  

Dear Moderator,

it should not work for some users, but for all, or at least most! 😎 

With me, APP hangs itself also at the start, no matter which
version is installed.
But the amazing thing is, sometimes it works 1 time
after a new installation and at the 2. start it hangs up again. 

But I think you are working on a solution.

I'm no IT specialist, but my suspicion is direction JAVA?

 

With hopeful greetings


ReplyQuote
(@wvreeven)
Black Hole Admin
Joined: 2 years ago
Posts: 474
November 20, 2020 11:44  

@j-notht-online-de

Jürgen, of course it should work for all users. I didn't mean to imply that it shouldn't. However, it is hard to resolve the issue when it cannot be reproduced.

What version of APP are you using?

 

Thanks, Wouter


ReplyQuote
(@j-notht-online-de)
White Dwarf Customer
Joined: 1 year ago
Posts: 10
November 20, 2020 12:22  

Hello Wouter,

iMac 5 k - 2014

with 1,082 and 1,083 beta after conversion to Big Sure Crash - under Catalina before without problems!

On other computers Mac Pro 2011 / 2020 and Mac Mini 2019 under
Catalina at present also problem-free!

They also stay under Catalina for now! 

 


ReplyQuote
(@j-notht-online-de)
White Dwarf Customer
Joined: 1 year ago
Posts: 10
November 20, 2020 12:48  

Hello Wouter,

the mistake is like Paul Imm.

APP starts, the selection window directory and drive opens.
APP seems to be underneath it, but it is selection window what no longer reacts blocks.

Looks exactly like Pau Imm.


ReplyQuote
(@wvreeven)
Black Hole Admin
Joined: 2 years ago
Posts: 474
November 20, 2020 14:12  

Mabula has informed me that unfortunately at the moment he cannot provide any support for Big Sur due to other priorities. The advice is to stay at Catalina if possible.


ReplyQuote
(@wvreeven)
Black Hole Admin
Joined: 2 years ago
Posts: 474
November 20, 2020 15:21  

Edit: Please read on to the message by Mabula later on, SIP might work, but is not recommended as the issue is likely due to security settings.

We have discussed this matter further and there is something that may solve the issue. However, there may be unexpected side-effects leading to the possibility that other software may be affected.

In some cases when upgrading to a newer version of macOS leads to issues, resetting the SIP settings may help. This can be achieved as follows:

  • Reboot your MacBook into recovery mode, see https://support.apple.com/en-gb/HT201314
  • Login as a user with admin rights
  • Open a terminal from the Tools menu
  • Reset the SIP settings by typing
    • csrutil clear
  • Reboot the MacBook by typing
    • reboot

After resetting the SIP settings you will need to reinstall AstroPixelProcessor.

Note that the SIP settings affect all software, including the OS itself, of the MacBook. Perform this operation at your own risk.


ReplyQuote
(@supercreative)
Molecular Cloud Customer
Joined: 8 months ago
Posts: 5
November 20, 2020 19:43  

@wvreeven Thank you. I opened the enabled the "open anyway" option in the Security tab of System Preferences and it is indeed working again. All is well!


ReplyQuote
(@wvreeven)
Black Hole Admin
Joined: 2 years ago
Posts: 474
November 20, 2020 20:33  
Posted by: @supercreative

@wvreeven Thank you. I opened the enabled the "open anyway" option in the Security tab of System Preferences and it is indeed working again. All is well!

Good to know that that worked for you.

 


ReplyQuote
(@paul-from-northern-mi)
Red Giant Customer
Joined: 1 year ago
Posts: 50
November 21, 2020 00:41  
Posted by: @wvreeven

We have discussed this matter further and there is something that may solve the issue. However, there may be unexpected side-effects leading to the possibility that other software may be affected.

In some cases when upgrading to a newer version of macOS leads to issues, resetting the SIP settings may help. This can be achieved as follows:

  • Reboot your MacBook into recovery mode, see https://support.apple.com/en-gb/HT201314
  • Login as a user with admin rights
  • Open a terminal from the Tools menu
  • Reset the SIP settings by typing
    • csrutil clear
  • Reboot the MacBook by typing
    • reboot

After resetting the SIP settings you will need to reinstall AstroPixelProcessor.

Note that the SIP settings affect all software, including the OS itself, of the MacBook. Perform this operation at your own risk.

Thank you for this idea to try.  As this could potentially have negative consequences I will want to try getting all of my applications to a stage where I can be sure they can safely be reinstalled.  The other thought I had was doing a clean Mac install.  In either case I will want to make sure I won't lose more than I could maybe gain with the attempt.

More people have had a successful install with Big Sur than not.  It was reassuring however that someone has the identical start up issue that I have been seeing.  There might be another software similarity between our MacBooks.


ReplyQuote
(@mabula-admin)
Universe Admin
Joined: 4 years ago
Posts: 2502
November 23, 2020 19:53  

Hi all, @supercreative, @wvreeven, @vincent-mod, @j-notht-online-de, @paul-from-northern-mi, @eckhardv, @mkearl, @wornish

Okay, please forget resetting the SIP settings ;-). I don't think that will be the solution...

Please follow these instructions on Catalina and Big Sur:

installing-app-on-macos-catalina-big-sur-and-native-support-for-the-new-apple-m1-hardware

To be able to install APP on Catalina & Big Sur, you need to follow these directions:

  • Completely uninstall APP first if APPis already installed.
  • Delete all the DMG installers for APP that you have already downloaded (they will be permanently blocked and thus problematic).
  • Go to System Preferences -> Security & Privacy -> Allow APPs downloaded from App Store and identified developers
  • After you have changed the setting to Allow APPs downloaded from App Store and identified developers, download the DMG installer using our download links and then you should be able to install it.
  • If you still can not install APP, double check again the Security & Privacy settings and explicitely say that you allow APP.
  • Then to make APP completely work go again to the Security & Privacy settings, go to the privacy tab, make sure that AstroPixelProcessor is allowed to access your Files and Folders. (This is probably why on some Big Sur installations, APP seems to freeze when the Work Directory selection is being asked ;-), maybe the MacOS window that is asking this, is not visible/behind the APP main window)
AllowAccessToHomeDirectory

 

A good contact of mine, a long APP user as well, is a Technical Sales person for Apple Belgium. He has confirmed to me that this should work. He has been running APP on different Macs with Big Sur without problems. Even on the new M1 hardware, everything works with these guidelines.

The last step is probably why some APP users tend to think that APP freezes, I suspect the MacOS window that is asking the permission is not visible/hidden and thus is blocking everything until the question is answered.

Kind regards,

Mabula

This post was modified 2 months ago by Mabula-Admin

(@j-notht-online-de)
White Dwarf Customer
Joined: 1 year ago
Posts: 10
November 23, 2020 22:21  

Hello Mabula,

this works with 1.083 beta and 1.082 unfortunately not.

APP does not write the selected folder during installation to
the "Security folder".
After closing APP and opening a new one, freezes the selection window again.

What to do is the following, in the selection "Open APP at startup". then APP works again.

But after closing, APP nothing works without a restart, because APP does not know the location
saves.

Thanks for your commitment

Jürgen


ReplyQuote
(@rodolgo)
White Dwarf Customer
Joined: 1 year ago
Posts: 21
November 24, 2020 10:54  

@mabula-admin

Hello Mabula,

Unfortunately, both the latest stable or beta fail to run, even after applying the instructions you provided above.

I certainly can install it, but it doesn't run.

Running on Big Sur, see below:

image

Regarding this instruction:

Posted by: @mabula-admin

Then to make APP completely work go again to the Security & Privacy settings, go to the privacy tab, make sure that AstroPixelProcessor is allowed to access your Files and Folders. (This is probably why on some Big Sur installations, APP seems to freeze when the Work Directory selection is being asked ;-), maybe the MacOS window that is asking this, is not visible/behind the APP main window)

the app doesn't show in the Files and Folders and cannot be added manually either.

I even tried to grant access to the full disk manually, to no avail.

I'm stuck! 🙁

Thanks in advance for any hint!


ReplyQuote
(@favalessa)
White Dwarf Customer
Joined: 7 months ago
Posts: 17
November 25, 2020 17:39  

@j-notht-online-de

where is "open APP at startup"?

I installed 1.083beta on iMac with Big Sur. did all the security allow, even full disk access. freezes at startup, I clicked around to no avail, but after a few minutes screens flash and I was able to select a working directory.  not sure what I did to get it to respond.  

john


ReplyQuote
(@vincent-mod)
Universe Admin
Joined: 4 years ago
Posts: 2871
November 25, 2020 18:34  

Maybe there is a MacOS window asking for permissions hiding behind? We will continue to look into this. Mabula is going to show the procedures as well on video so maybe that may help. He now has an iMac Pro 2017, Macbook pro 2017 and both work fine, as well as the many other people reporting it works (even on a M1). So we think it might be something that's missed somehow on certain computers. I hope the video might give a hint in that sense.


ReplyQuote
(@j-notht-online-de)
White Dwarf Customer
Joined: 1 year ago
Posts: 10
November 25, 2020 18:40  

Hello John,

in the following order:

Remove APP and reinstall it!
At the first start in the Dock the following steps

1) in the Dock >APP icon > "open at startup" > Set check mark
2.) Mac > Restart
3.) APP starts clean
4.) Select directory > APP runs as usual
5.) Terminate APP > restart in running system
6.) and then the error is back 🙁
7.) on restart it starts again from point 3.)

8.) So this is also not a practicable permanent solution! 🙁

Jürgen


ReplyQuote
(@j-notht-online-de)
White Dwarf Customer
Joined: 1 year ago
Posts: 10
November 25, 2020 18:57  

Do the users for whom there are no problems
from "Catalina" to "Big Sur", an update from
made?
Or "Big Sur" newly installed!

Maybe during the update, migrated data causes
from "Catalina" the mistake?

But it is also poking in the fog

 

Jürgen

This post was modified 2 months ago by Jürgen Noth

ReplyQuote
(@vincent-mod)
Universe Admin
Joined: 4 years ago
Posts: 2871
November 25, 2020 19:00  

Good question, I think it's a mix. Most seem to have upgraded. We are on top of this as we try to pinpoint what might be the case. Problem is that we can't really reproduce this behaviour on our machines (apart from what Mabula mentions in his step by step guide).


ReplyQuote
(@j-notht-online-de)
White Dwarf Customer
Joined: 1 year ago
Posts: 10
November 25, 2020 19:17  

Hello Vincent,

when I have time, next week, i-Mac 2014 with Big Sur
cleanly new set up! Let's see what happens!

On my Mac Books Pro 16" with Catalina runs all clean! 1.082 and 1.083 beta!

Is therefore a luxury problem for me, if it is on the i-Mac with Big Sur not running. 🙂

But it would still be nice 🙂

Jürgen

 


ReplyQuote
Page 3 / 6
Share: