Share:
Notifications
Clear all

2022-05-29: APP 2.0.0-beta2 has been released !

Release notes

Download links per platform:

windows 2.0.0-beta2

macOS x86_64 2.0.0-beta2

macOS arm64 M1 2.0.0-beta2

Linux DEB 2.0.0-beta2

Linux RPM 2.0.0-beta2

[Sticky] I can't adjust APP's memory with the CFG button ! It's always the same when I start APP...

Page 1 / 2

(@mabula-admin)
Quasar Admin
Joined: 5 years ago
Posts: 3159
Topic starter  

Hi all,

Astro Pixel Processor is an Oracle JAVA application and the startup parameters of JAVA to run APP properly are configured in the APP installation files. You should never have to alter these yourself.

However, some other application builders have the bad habit of asking the user to set JAVA startup parameters on the Operating System level.  This is not good.

This means that all Java applications on your operating system, will only be able to run with the settings that are set on the Operating System level, because they will overrule the settings on application level.

So which operating system level envrionment variable is concerned here? It's the variable

_JAVA_OPTIONS

with argument -XmxXXXXM or -XmxXG

The XXXXM could be 1024M, in this case, any Java process could only use a maximum of 1024MB=1GB of memory. 2G means 2GB.

APP by default will start on a new installation with 2GB's of memory available. If this is not the case, then this environment variable is very likely to be set on your Operating System level.

If the variable is set, you will need to delete it (or alter it to influence the amount of memory that APP can use). Below are general instructions on how to find and delete the variable so APP can function properly :

Windows:

Right click on windows start:

System, system info, advanced system settings, Environment Variables

Here is an explanation as well:

https://www.computerhope.com/issues/ch000549.htm

MacOS & Linux:

This is probably a bit more complicated than on windows, because it can depend on which MacOS version you are or which shell you have on your Linux distribution, here is a general article that could help you in this regard:

https://support.foundry.com/hc/en-us/articles/209642805-Q100127-How-to-delete-unset-environment-variables

If you do a search on a searchengine, you are bound to found a way to solve this for your MacOS version or Linux distribution.

If you need help with deleting the envrionment variable on your computer, please let us know 😉

Kind regards,

Mabula

This topic was modified 3 years ago 5 times by Mabula-Admin

ReplyQuote
(@mikecmp)
White Dwarf Customer
Joined: 2 years ago
Posts: 25
 

Actually, I think for the Mac version at least, this is a bug in the packaging of APP

Once installed, If I open contents of APP, and go into contents/java/AstropixelPriocessor.cfg There is a option under "JVMOptions" for -Xmx2g

The UI showed the correct value that I had set, but this file did not have the value updated. Once I changed this file and saved it, I saw APP use the correct amount of ram, or at least over 2gb 

I think that APP just needs to write the user specified value to this file as well and it would solve this problem on the Mac. 

 

Not a Java expert by any stretch! But this is how I solved the problem on my Mac

 

Mike


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4850
 

Very interesting Mike, I'll forward this to Mabula.


ReplyQuote
(@mikecmp)
White Dwarf Customer
Joined: 2 years ago
Posts: 25
 

Sure thing - I found it as the second answer here:

 

https://stackoverflow.com/questions/10887518/change-max-memory-heap-for-java-on-mac-os-x


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 5 years ago
Posts: 3159
Topic starter  
Posted by: @mikecmp

Actually, I think for the Mac version at least, this is a bug in the packaging of APP

Once installed, If I open contents of APP, and go into contents/java/AstropixelPriocessor.cfg There is a option under "JVMOptions" for -Xmx2g

The UI showed the correct value that I had set, but this file did not have the value updated. Once I changed this file and saved it, I saw APP use the correct amount of ram, or at least over 2gb 

I think that APP just needs to write the user specified value to this file as well and it would solve this problem on the Mac. 

 

Not a Java expert by any stretch! But this is how I solved the problem on my Mac

 

Mike

H Michael @mikecmp & @vincent-mod,

This is NOT AN ERROR of APP's packaging really. APP uses the java 8 packager.

This topic concern's operating system's where for some reason other software builders had a problem with packaging... 🙂

Setting Java options on the operating system level is not smart and older java software packages used to do this... so if the operating system has this value _JAVA_OPTIONS then you need to remove this and APP will work as expected and according to modern java packaging.

To be clear, a user should never have to alter : AstropixelPriocessor.cfg

You can simply click on the CFG button in APP to change memory of APP, it will be applied after a restart. And the CFG should NOT be adjusted, this is not how that works...

The UI showed the correct value that I had set, but this file did not have the value updated. Once I changed this file and saved it, I saw APP use the correct amount of ram, or at least over 2gb

I think that APP just needs to write the user specified value to this file as well and it would solve this problem on the Mac.

And this is controlled on the user level. The CFG file regarding JVMOptions" for -Xmx2g is for general first time installation. Once APP has been started, the actual configuration is saved on the user account on for instance MacOS and Windows. So, the cfg file should not be changed by the user !

On all MacOS versions from sierra to Catalina, app works properly with memory management using only the CFG button in APP. I have never instructed users to change the CFG file, and they shouldn't need to do so.

It will only NOT work if _JAVA_OPTIONS are set on the Operating System level, which you never want to do. Older MacOS installation with legacy software might have this issue and that issue is caused by legacy software NOT using proper packaging, really 😉

Mabula


ReplyQuote
(@mikecmp)
White Dwarf Customer
Joined: 2 years ago
Posts: 25
 

Interesting - I will poke around more - for now modifying the config in the app works for me, I'll try to hunt down the root of the problem with the installed version of the software.

Its possible i set something up incorrectly - I used this machine for work for several clients, all of whom had different software versions , etc. So i probably have a config buried somewhere I did not uncover. 

 

Thanks for the response, appreciate it and love APP

 

Mike


ReplyQuote
(@saarimann)
Hydrogen Atom Customer
Joined: 2 years ago
Posts: 1
 

Hey, i have a Problem with the memory too. When i click on cfg nothing happens? I use Windows 10. I find the Variables with the instruction, but i dont know which one to delete? Can someone please help with this?

Encountered error in module:
AlignAndResampler

Error message:
java.lang.OutOfMemoryError: Java heap space

Cause:
Java heap space
d.a(Unknown Source)
d.doInBackground(Unknown Source)
javax.swing.SwingWorker$1.call(SwingWorker.java:295)
java.util.concurrent.FutureTask.run(FutureTask.java:266)

Thanks 

Alex


ReplyQuote
(@l-belien)
Hydrogen Atom Customer
Joined: 4 years ago
Posts: 2
 

Same here.  Reported this issue a few months ago, but received no feedback or possible solution. Still hoping to get this resolved.

Lambert


ReplyQuote
(@aro)
Molecular Cloud Customer
Joined: 1 year ago
Posts: 5
 

Hello everybody

I have the same problem, I can't adjust ram memory. The windows config didn't open when I click on button CFG. My config is Windows 10  32GB of RAM memory.

I have another small computer and it works on it.

Could you tell me how i can fix the problem.

I didn't find the varible JAVA in the system?

Thanks a lot Stéphane


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4850
 

I have notified Mabula again, it remains a weird problem that only happens for some. We will look into it again. If you are on Windows you can find environment variables here; go to the control panel and type in "environment variables", click on the "edit variables" option and then you should be able to see them (both for the user level and system level). If there is an option there for _JAVA_OPTIONS that might cause an issue apparently. But I would be surprised if that is the case for you. Be careful removing thins in there btw, it could be other software uses it.


ReplyQuote
(@aro)
Molecular Cloud Customer
Joined: 1 year ago
Posts: 5
 

@vincent-mod

Thanks for the answer. I have checked but I didn't find _JAVA_OPTIONS in the environnement variables.

How can I fix it for the moment?


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 5 years ago
Posts: 3159
Topic starter  

@aro & @l-belien,

In which way are you starting Astro Pixel Processor and on which Operating System? The CFG will not work if you don't start APP they way it is supposed to ;-).

After installation of the application, what exactly do you do to get Astro Pixel Processor to start?

Mabula

 


ReplyQuote
(@aro)
Molecular Cloud Customer
Joined: 1 year ago
Posts: 5
 

Hello

Tell How I have to install it and launch it?

May be I have to desinstall and reinstal it?

Tell me.

My operating system is windows10


ReplyQuote
(@l-belien)
Hydrogen Atom Customer
Joined: 4 years ago
Posts: 2
 

@mabula-admin

Hi Mabula, I've been strolling arround the forum and I found the solution to be set in the environnement variables. Although I am not a advanced programmer, I tried to alter the variables, defining the JAVA settings and succesfully applied 30 G of RAM memory to be adressed to the proper working of APP. My configuration is Windows 10  on a ASUS ZenBook Duo Pro with a I9 processor and 32G Ram. Now everything is working smoothly, but.......the CFG-button is still not reponding to the click. No problem because the system is getting all the RAM it needs.


ReplyQuote
(@aro)
Molecular Cloud Customer
Joined: 1 year ago
Posts: 5
 

hello l.belien

 

Could you tell me precisely how to do it??

Thanks a lot

 

Stéphane


ReplyQuote
(@aro)
Molecular Cloud Customer
Joined: 1 year ago
Posts: 5
 

hello l.belien

 

Could you help me please?

 Stéphane


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 5 years ago
Posts: 3159
Topic starter  
Posted by: @l-belien

@mabula-admin

Hi Mabula, I've been strolling arround the forum and I found the solution to be set in the environnement variables. Although I am not a advanced programmer, I tried to alter the variables, defining the JAVA settings and succesfully applied 30 G of RAM memory to be adressed to the proper working of APP. My configuration is Windows 10  on a ASUS ZenBook Duo Pro with a I9 processor and 32G Ram. Now everything is working smoothly, but.......the CFG-button is still not reponding to the click. No problem because the system is getting all the RAM it needs.

@l-belien, @aro

That is not a good solution at all, since the operating system variables will hold for any java application.

That is why it needs to be done on the application level, not on the Operating System level.

If you install Astro Pixel Processor correctly and start it with the link in Windows Start Menu -> Aries Productions -> Astro Pixel Processor.

The CFG button should work in that case.

If it works, but the memory is not adjusted after a restart, then there is the Operating System variable that is causing this. It overrrules which you don't want. So then you need to remove the variable.

If it does not work, so you don't see the CFG Menu pop-up, I think a system specific bug might be triggered somehow and it would be best if I have a look on your computer with Teamviewer for instance to solve this?

Kind regards,

Mabula

This post was modified 1 year ago by Mabula-Admin

ReplyQuote
(@moon314)
Hydrogen Atom Customer
Joined: 8 months ago
Posts: 1
 

Folks, I could enable CFG button by uninstalling and re-installing APP at the top directory (C:\APP). The cause of my trouble appeared to come from my username of Kanji (Japanese character) for windows 10. I hope this will help.


ReplyQuote
(@michel1276)
Hydrogen Atom Customer
Joined: 3 years ago
Posts: 3
 

While looking for a solution to this problem, I found the thread here.

Maybe someone can help.

I got my new computer with 128 GB RAM, and installed 1.83.4 to work with. But it says, that only 2048 are used, and CFG Button doesn´t work. 

I tried new installation 4 times now, even with older 1.83.3 Version, but it´s still not active = pop up menu does NOT open. 

I also tried this java application thing, but it also didn´t help.

I have Windows 11 PRO - 64 Bit

12th Gen Intel(R) Core(TM) i5-12600K 3.70 GHz

128 GB RAM


ReplyQuote
(@wvreeven)
Galaxy Admin
Joined: 4 years ago
Posts: 1723
 

@michel1276 Michael, did you install APP on the C drive?


ReplyQuote
Page 1 / 2
Share: