Critical Warning - ...
 
Share:
Notifications
Clear all

2022-05-29: APP 2.0.0-beta2 has been released !

Release notes

Download links per platform:

windows 2.0.0-beta2

macOS x86_64 2.0.0-beta2

macOS arm64 M1 2.0.0-beta2

Linux DEB 2.0.0-beta2

Linux RPM 2.0.0-beta2

Critical Warning - Flat Field Calibration Can not be Performed Correctly

Page 2 / 2

(@midnight_lightning)
Red Giant Customer
Joined: 4 years ago
Posts: 104
Topic starter  
Posted by: @mabula-admin

So I can only assume that you are loading the frames differently for some reason?

I have compared the loading tables for the Successful and Errored runs and they are identical in every respect. It is possible they were loaded differently, e.g. loading lights for all sessions before moving on to flats vs loading all subs for session 1 before doing session 2, but the resulting load details are identical.   

We still haven't ascertained why, in previous runs, trying to calibrate two or three of the sessions at once failed whilst calibrating them individually was always successful. These tests were done using the same loaded data, only changing the data selected for each run - the data was not reloaded between tests. 

There is also the issue whereby files loaded in one step subsequently disappear after loading the next step - all assigned explicitly.

I worked in Computer Systems Development for forty years, from CICS Assembler programmer to Department Head, and I know if a user came to me with this kind of issue it would turn out to be user error 99% of the time. Whilst I can never be 100% certain that it isn't user error now I have been rigorous in my testing and am 99.9% certain there is an intermittent problem somewhere, possibly outside APP if I am the only person affected.      

Unfortunately I am not yet able to replicate the issue but will report back when the problem next occurs.

Thanks again for your help - I have in any case learned some new things that will improve my processes going forward 😀 

 


ReplyQuote
(@midnight_lightning)
Red Giant Customer
Joined: 4 years ago
Posts: 104
Topic starter  
Posted by: @mabula-admin

So I can only assume that you are loading the frames differently for some reason?

@mabula-admin

I just spent 30 minutes documenting the latest failed integration in fine detail, unfortunately when I attached the file below your system deleted everything I had typed. I don't have time to go through all that again.

Basically, I tried to pre-process my latest data,  NGC1333 with 4 Sessions of RGB and it failed in exactly the same way as the original post above.

Yet each session run individually worked fine and produced good Integrations.

Given past experience I used a very precise process to demonstrate the anticipated issue.

I initially loaded S1 data only and ran that thorough with defaults (except Normalisation where I didn't use Neutralise Background). It worked fine. 

I then "deselected" S1 data files, "removed" output files from the file list, moved the actual output files to new folder. 

I then repeated the above for S2, S3 and S4. 

All individual sessions ran successfully. 

I then selected all data files (all sessions) - NB I did not reload any files - the selected files were the ones used for the original individual sessions, and re-ran.

It failed in the same way as indicated at the start of this thread. 

There is something wrong somewhere. 

I have attached spreadsheet showing the File List (Note the job continued to run for a minute after cancelling so it's possible that an output file(s) was created after the error. I can't find the log, I assume it is saved somewhere? 

I estimate I have spent several weeks of time over the past year with similar issues and frankly don't have time to keep doing this. I would really like to be able to use APP but for now I will use PixInsight which always seems to run through without issue.

Happy to provide the data for investigation, 799 files @ 120mb each.   

 

 

  


ReplyQuote
(@midnight_lightning)
Red Giant Customer
Joined: 4 years ago
Posts: 104
Topic starter  

Any thoughts?


ReplyQuote
(@vincent-mod)
Quasar Admin
Joined: 5 years ago
Posts: 4918
 

I asked Mabula to have a look. 😉


ReplyQuote
Page 2 / 2
Share: