Be aware of capture...
 
Share:
Notifications
Clear all

Black Friday & Cyber Monday Sales on Renter's & Owner's licenses - sale will end on the 1st of December 2020 at 12:00 UTC

16 November 2020 - Wouter van Reeven has officially joined the Astro Pixel Processor Team as a moderator on our forum, welcome Wouter 🙂 !

31 July 2020 - Comet Registration video tutorial using APP 1.083-beta1 released.

30 July 2020 - APP 1.083-beta1 has been released introducing Comet processing! This 1st beta has comet registration. The stable release will also include special comet integration modes.

9 July 2020 - New and updated video tutorial using APP 1.081: Complete LRGB Tutorial of NGC292, The Small Magellanic Cloud by Christian Sasse (iTelescope.net) and Mabula Haverkamp

2019 September: Astro Pixel Processor and iTelescope.net celebrate a new Partnership!

[Sticky] Be aware of capture programs and what they write to the FITS headers  

Page 1 / 2
  RSS

(@regpratt)
Main Sequence Star Customer
Joined: 6 months ago
Posts: 25
August 14, 2020 04:11  

I am trying to stack data from different image trains as done in this video:

https://www.astropixelprocessor.com/registration-normalization-integration-using-ddc-lnc-mbb/

 

Both data sets are pre-calibrated in APP (but by different people. I loaded the Ha sets as Ha filter but gave them their own session. Same with the Oiii sets. When I get to the normalization step, I get this error immediately. All the data sets have been successfully stacked on their own, this only happens when trying to stack the 2 data sets together. Any help would be greatly appreciated.

Annotation 2020 08 13 185644

 

I copied all the settings to be the same as the video:

 

 

 

 

flip desciprtors in x/y (tried both checked and unchecked)

use dynamic distortion correction checked

same camera and optics unchecked

 

Normalize Mode: Advanced

Multiply-scale

BMV

 

Integrate: Average

Weights: Quality

Local Normalization Rejection checked

Filter: sigma clipping

 

LNC: 2nd degree LNC

 

MBB 10%

 


ReplyQuote
Topic Tags
(@regpratt)
Main Sequence Star Customer
Joined: 6 months ago
Posts: 25
August 14, 2020 04:47  

Update:

 

I tired unchecking multi-filter and multi-session and loaded all the Ha subs as a single session. This time normalization got to 54% before giving the same error as before but this time with no cause.

 

Annotation 2020 08 13 194439

ReplyQuote
(@vincent-mod)
Universe Admin
Joined: 3 years ago
Posts: 2665
August 14, 2020 14:53  

Strange. The fact you have pre-calibrated data is interesting though, I'm wondering if one of those is causing an issue for some reason. Could you check if it works with combining just 2 (in the hope you miss the possible wrong one)?


ReplyQuote
(@regpratt)
Main Sequence Star Customer
Joined: 6 months ago
Posts: 25
August 14, 2020 16:32  

I tried combining 2 subs (one from each set) and got the same issue. I just noticed that one set is showing a bayer pattern in the CFA column while the other isnt. This is weird because both sets are from a mono camera. Could this have something to do with it?

 

Annotation 2020 08 14 073055

ReplyQuote
(@vincent-mod)
Universe Admin
Joined: 3 years ago
Posts: 2665
August 14, 2020 21:34  

Might be, as the crash happens in the normalization this usually is the case when combining broadband data with mono. This may also have been done by the one who precalibrated the data, can you ask him for his un-calibrated mono and his calibration frames so you can test with at least the exact same settings?


ReplyQuote
(@regpratt)
Main Sequence Star Customer
Joined: 6 months ago
Posts: 25
August 14, 2020 21:45  

@vincent-mod

 

So I use Astrophotography Tool to capture my data. There is a setting that debayers the captured fits files so that you can see OSC subs in color on the preview screen. Turns out by leaving that setting on while capturing mono data, it appears to add the Bayer matrix in anyway.

 

I tested this by plugging in my Asi183mm and taking single sub with Bayer preview enabled. I loaded that sub into APP and it shows RGGB under the CFA tab no matter what setting I changed in tab 0. I deselected Bayer preview in APP and took another sub, loaded it into APP, no CFA reports "None". So I think APP was seeing my subs as color even though they weren't because of the ATP setting. I won't be able to verify this with actual data for a few more nights when I get clear skies but I'm pretty sure that was the problem. 


ReplyQuote
(@vincent-mod)
Universe Admin
Joined: 3 years ago
Posts: 2665
August 14, 2020 21:49  

Ah yes, that might be the issue then. APP does look at the FITS headers to see what type of data was taken. Nice one you thought of that!


ReplyQuote
(@regpratt)
Main Sequence Star Customer
Joined: 6 months ago
Posts: 25
August 14, 2020 21:51  

That stinks because that means 11 hours of data is now unusable 😩. It's OK though I'm just glad to have figured it out, we've been working on figuring this out all week. I didn't think that ATP setting mattered because it's called "Bayer preview" implying it only effects the preview and not the actual fits file. Lesson learned. When I verify this with actual data I'll report back, maybe this information can be stickied or something so that other ATP users are aware. 


ReplyQuote
(@vincent-mod)
Universe Admin
Joined: 3 years ago
Posts: 2665
August 14, 2020 21:58  

Well, maaaaaaybe there is a way to remove that pattern from the headers? Never done that myself, but there must be something to do that... I asked Mabula.


ReplyQuote
(@regpratt)
Main Sequence Star Customer
Joined: 6 months ago
Posts: 25
August 14, 2020 21:59  

Yeah, my next step is to see if I can somehow wipe the Bayer pattern off the files. I tried doing an extract Ha on them in APP but that didn't work 


 


ReplyQuote
(@vincent-mod)
Universe Admin
Joined: 3 years ago
Posts: 2665
August 14, 2020 22:02  

Just made you a sticky, I think it's a good general warning.


ReplyQuote
(@vincent-mod)
Universe Admin
Joined: 3 years ago
Posts: 2665
August 15, 2020 11:54  

Ok, so talked with Mabula. Both him and me never saw this before, so there's no super easy solution yet (unless you can find a meta data editor). He's thinking about making this possible in the batch modify tool, so don't throw away the data and don't recapture just yet (unless you want even more data). In batch modify there is a way to edit the header, but not to switch off a bayer pattern, it's likely never needed but will solve your issue. He added it to his to-do list.


ReplyQuote
(@vincent-mod)
Universe Admin
Joined: 3 years ago
Posts: 2665
August 15, 2020 11:57  

Oh and he offered to fix this in between for you to speed things up, so if you want you can upload the data to our server, he'll fix it and you can download it again.

Go to https://upload.astropixelprocessor.com and use upload1 (or upload2 till 5) as username and password will then be the same as the username.

Create a directory named “regpratt-bayerpatterninmono” and upload in there. Thank you!

 


ReplyQuote
(@regpratt)
Main Sequence Star Customer
Joined: 6 months ago
Posts: 25
August 15, 2020 15:17  

@vincent-mod

 

I really appreciate the help. The files are uploading now but its 9gb of data so its going to take a few hours 🤣 


ReplyQuote
(@vincent-mod)
Universe Admin
Joined: 3 years ago
Posts: 2665
August 15, 2020 20:21  

Oh no worries. 🙂 So there is maybe another way, you can also select "no interpolation" as option. That might work as well, can you try?


ReplyQuote
(@regpratt)
Main Sequence Star Customer
Joined: 6 months ago
Posts: 25
August 15, 2020 20:41  

I tried that last night and it didn't work. I'm actually going to cancel the upload when I get home because I found an Windows application that allows you to strip the Bayer info out of the header. I tested it on a single sub and after loading it in APP it was no longer showing anything under CFA so worse case scenario that will work I just have to change them one by one. 


ReplyQuote
(@vincent-mod)
Universe Admin
Joined: 3 years ago
Posts: 2665
August 15, 2020 21:18  

Ok we can do that in 1 go if you want, but whatever you find easiest.

Did you reload the data after you changed to the "no interpolation" setting? I'm not talking about the "force cfa" option, to be clear.


ReplyQuote
(@regpratt)
Main Sequence Star Customer
Joined: 6 months ago
Posts: 25
August 16, 2020 00:04  
Posted by: @vincent-mod

Ok we can do that in 1 go if you want, but whatever you find easiest.

Did you reload the data after you changed to the "no interpolation" setting? I'm not talking about the "force cfa" option, to be clear.

That would be great, I just got home and noticed the upload was done anyway. Thanks!


ReplyQuote
(@xsnrg)
Main Sequence Star Customer
Joined: 3 years ago
Posts: 33
August 23, 2020 23:49  

Greetings all. I stumbled upon this same error. In my case, I have data that was captured with an OSC camera, 1600MC, and a Luminance filter on a 1600MM at a later time.  I load each of these into a session and get to the normalization and then get the exact error above.

I have multi-session and multi-filter checked, and all the defaults on the normalize tab. On trying to re-run it, I can also get this error:

Encountered error in module:
OverlapBetweenTwoImageObjectsCreatorWorker

Error message:
java.lang.ArrayIndexOutOfBoundsException

Cause:
null
no trace

I did have same camera and optics selected though, so I cleared this and ran it again but had the same error.

 

This post was modified 3 months ago by xsnrg

ReplyQuote
(@regpratt)
Main Sequence Star Customer
Joined: 6 months ago
Posts: 25
August 24, 2020 00:18  

@xsnrg

You need to convert the 1600MC data to mono before combining with the 1600mm data. This error happens when you try and combine color and mono data. Use extract Ha or extract Ha-Oiii mono if you want lum then combine that with the 1600mm data. 


ReplyQuote
Page 1 / 2
Share: