Share:

APP 1.075 has been released !

Forum support from Vincent will be limited between now and  Oktober the 30th, 2019. Mabula will be available for support on the forum though.

2019 September: Astro Pixel Processor and iTelescope.net celebrate a new Partnership!

OpenGL Button  

  RSS

(@minusman)
Neutron Star Customer
Joined: 2 years ago
Posts: 117
March 9, 2019 14:46  

Hi Mabula, I have installed APP in my Ubuntu 18.04.
I noticed that.
The OpenGL symbol is always yellow after an update from OpenGL 3.0 to 4.5 so not active. A mouse click on the symbol does not cause a
change.

Bildschirmfoto von 2019 03 09 14 34 20

This topic was modified 8 months ago by Mabula Haverkamp - Admin

ReplyQuote
Topic Tags
(@mabula-admin)
Quasar Admin
Joined: 3 years ago
Posts: 2148
March 9, 2019 23:34  

Hi @minusman,

If the OpenGL symbol is yellow, it would usually mean that there is a problem with the OpenGL driver, for some reason the OpenGL initialization fails.

Perhaps you can elaborate about:

"The OpenGL symbol is always yellow after an update from OpenGL 3.0 to 4.5"

So, I assume you update your graphics drivers and then OpenGL in APP is broken ?

Can you tell me which graphics card and which OpenGL drivers you are installing?

Kind regards,

Mabula

Main developer of Astro Pixel Processor and owner of Aries Productions


ReplyQuote
(@minusman)
Neutron Star Customer
Joined: 2 years ago
Posts: 117
March 10, 2019 00:38  

I have a Radeon Fury X graphics card. The driver is the Mesa 18.3.3 which is included in the Padoka Stable PPA( https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/pkppa).

With best regards,

Henry


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 3 years ago
Posts: 2148
March 12, 2019 20:41  

Hi @minusman,

Okay thanks, we need to do some testing and get some output from your Ubuntu + Mesa 18.3.3 installation to solve this.

Can you open a terminal/console and run the glxinfo command?

Can you send me all output?

I will try to create a test installer that will extract all output of the opengl initialization on your computer, which should tell us a lot more 😉

Mabula

Main developer of Astro Pixel Processor and owner of Aries Productions


ReplyQuote
(@mabula-admin)
Quasar Admin
Joined: 3 years ago
Posts: 2148
March 12, 2019 23:14  

Hi @minusman,

I just got confrimation, that there is an issue with the opengl library that APP uses and the latest version(s) of Mesa under GNU Linux... so you must be triggering this.

I know that this issue is being dealt with.

So for now, I suggest, you use a bit older Mesa version on which the OpenGL initialization does work. In the meantime, I'll communicate with the opengl library people on what I can do to speed-up the fix. Okay?

Kind regards,

Mabula

Main developer of Astro Pixel Processor and owner of Aries Productions


ReplyQuote
(@minusman)
Neutron Star Customer
Joined: 2 years ago
Posts: 117
March 12, 2019 23:35  

It's okay,Mabula. It's not so bad at the moment, the CPU rendering is luckily still available. I need the latest Mesa version for other software that needs it. I can make a screenshot only at the weekend.
With kind regards.


ReplyQuote
Share: